summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRodrigo Bezerra2015-06-08 18:03:17 -0300
committerRodrigo Bezerra2015-06-08 18:03:17 -0300
commit2458a495c8b7ff96c4b41dfe0c8501ee5f054c52 (patch)
treefdc394369632a514c6f4a6711e2734b9d0d1b1a2
downloadaur-2458a495c8b7ff96c4b41dfe0c8501ee5f054c52.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--LICENSE67
-rw-r--r--PKGBUILD30
-rw-r--r--drjava.desktop9
-rw-r--r--drjava.sh3
5 files changed, 131 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c0527e1a4ed3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by makepkg 4.2.1
+# Mon Jun 1 15:55:57 UTC 2015
+pkgbase = drjava
+ pkgdesc = A lightweight development environment for writing Java programs
+ pkgver = 20140826
+ pkgrel = 1
+ url = http://www.drjava.org/
+ arch = any
+ license = BSD
+ depends = bash
+ depends = java-environment
+ source = http://downloads.sourceforge.net/sourceforge/drjava/drjava-stable-20140826-r5761.jar
+ source = drjava.sh
+ source = drjava.desktop
+ source = LICENSE
+ md5sums = b637ffbab909fc8c03f333d55bc59237
+ md5sums = a57baea903b23dc546d8ad0ec016ec93
+ md5sums = df1e9a8e696b70ad57b1adc33a1ea19a
+ md5sums = 2108800ef4928c954af10f1c44bcddfd
+
+pkgname = drjava
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..58729b4e65da
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,67 @@
+DrJava is released under a standard BSD open-source license. The full text
+follows.
+
+ Copyright (c) 2001-2008, JavaPLT group at Rice University
+(drjava@rice.edu) All rights reserved.
+
+ Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above
+copyright notice, this list of conditions and the following disclaimer in
+the documentation and/or other materials provided with the distribution.
+ * Neither the names of DrJava, the JavaPLT group, Rice University,
+nor the names of its contributors may be used to endorse or promote
+products derived from this software without specific prior written
+permission.
+
+ THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
+EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
+PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
+LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+ This software is Open Source Initiative approved Open Source Software.
+Open Source Initative Approved is a trademark of the Open Source
+Initiative.
+
+ Download the current version of this project from
+http://www.drjava.org/ or http://sourceforge.net/projects/drjava/
+
+DrJava incorporates and extends DynamicJava (originally available at
+http://koala.ilog.fr/djava), which is licensed under these terms:
+
+ DynamicJava - Copyright (c) 1999 Dyade
+
+ Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to permit
+persons to whom the Software is furnished to do so, subject to the
+following conditions:
+
+ The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN
+NO EVENT SHALL DYADE BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY,
+WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF
+OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE
+
+ Except as contained in this notice, the name of Dyade shall not be
+used in advertising or otherwise to promote the sale, use or other
+dealings in this Software without prior written authorization from Dyade.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f9ac269d532a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Rodrigo Bezerra <rodrigobezerra21 at gmail dot com>
+# Contributor: Nathan Owe <ndowens.aur at gmail dot com>
+
+pkgname=drjava
+pkgver=20140826
+_realver=stable-${pkgver}-r5761
+pkgrel=1
+pkgdesc="A lightweight development environment for writing Java programs"
+arch=('any')
+url="http://www.drjava.org/"
+license=('BSD')
+depends=('bash' 'java-environment')
+source=(http://downloads.sourceforge.net/sourceforge/drjava/drjava-${_realver}.jar
+ 'drjava.sh' 'drjava.desktop' 'LICENSE')
+md5sums=('b637ffbab909fc8c03f333d55bc59237'
+ 'a57baea903b23dc546d8ad0ec016ec93'
+ 'df1e9a8e696b70ad57b1adc33a1ea19a'
+ '2108800ef4928c954af10f1c44bcddfd')
+
+package()
+{
+ cd ${srcdir}/
+
+ install -d ${pkgdir}/usr/share/{java/${pkgname},licenses/${pkgname}}
+ install -Dm644 drjava-${_realver}.jar ${pkgdir}/usr/share/java/${pkgname}/drjava.jar
+ install -Dm755 drjava.sh ${pkgdir}/usr/bin/drjava
+ install -Dm644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm644 edu/rice/cs/drjava/ui/icons/drjava64.png ${pkgdir}/usr/share/pixmaps/drjava.png
+ install -Dm644 drjava.desktop ${pkgdir}/usr/share/applications/drjava.desktop
+}
diff --git a/drjava.desktop b/drjava.desktop
new file mode 100644
index 000000000000..2a83f6b91eaf
--- /dev/null
+++ b/drjava.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=DrJava
+Comment=Lightweight development environment for writing Java programs
+Exec=drjava
+Icon=drjava
+Terminal=false
+Categories=Development;Education;Java; \ No newline at end of file
diff --git a/drjava.sh b/drjava.sh
new file mode 100644
index 000000000000..3f67b0e34626
--- /dev/null
+++ b/drjava.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+"$JAVA_HOME/bin/java" -jar '/usr/share/java/drjava/drjava.jar'