summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Engestrom2017-04-26 23:33:16 +0100
committerEric Engestrom2017-04-26 23:33:16 +0100
commit1f96ad544c132ae1ace15619eac024f0191a575e (patch)
tree90b26cd0940031704572834f51d6abface79e1b2
parentfbb3a821e676a05a3629315f6584fce2cdafa5f0 (diff)
downloadaur-1f96ad544c132ae1ace15619eac024f0191a575e.tar.gz
commit missing patches
-rw-r--r--0001-include-drm_fourcc.h-from-libdrm-not-the-kernel.patch55
-rw-r--r--0002-meson-install-drminfo-drmtest.patch37
-rw-r--r--0003-meson-install-drminfo-drmtest-man-pages.patch53
3 files changed, 145 insertions, 0 deletions
diff --git a/0001-include-drm_fourcc.h-from-libdrm-not-the-kernel.patch b/0001-include-drm_fourcc.h-from-libdrm-not-the-kernel.patch
new file mode 100644
index 000000000000..aa7ddb63d472
--- /dev/null
+++ b/0001-include-drm_fourcc.h-from-libdrm-not-the-kernel.patch
@@ -0,0 +1,55 @@
+From 1ffeb1d4cfb900a241f4a8a09efd4ac18f1311dc Mon Sep 17 00:00:00 2001
+From: Eric Engestrom <eric.engestrom@imgtec.com>
+Date: Tue, 25 Apr 2017 10:49:39 +0100
+Subject: [PATCH drminfo] include drm_fourcc.h from libdrm, not the kernel
+
+Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com>
+---
+ drminfo.c | 2 +-
+ drmtest.c | 2 +-
+ drmtools.c | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/drminfo.c b/drminfo.c
+index 43a4fac..195298f 100644
+--- a/drminfo.c
++++ b/drminfo.c
+@@ -9,7 +9,7 @@
+ #include <getopt.h>
+
+ #include <sys/ioctl.h>
+-#include <drm/drm_fourcc.h>
++#include <libdrm/drm_fourcc.h>
+
+ #include <xf86drm.h>
+ #include <xf86drmMode.h>
+diff --git a/drmtest.c b/drmtest.c
+index 4266149..2e9216a 100644
+--- a/drmtest.c
++++ b/drmtest.c
+@@ -13,7 +13,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/mman.h>
+ #include <sys/time.h>
+-#include <drm/drm_fourcc.h>
++#include <libdrm/drm_fourcc.h>
+
+ #include <xf86drm.h>
+ #include <xf86drmMode.h>
+diff --git a/drmtools.c b/drmtools.c
+index 581886a..c71ddae 100644
+--- a/drmtools.c
++++ b/drmtools.c
+@@ -8,7 +8,7 @@
+ #include <inttypes.h>
+
+ #include <sys/ioctl.h>
+-#include <drm/drm_fourcc.h>
++#include <libdrm/drm_fourcc.h>
+
+ #include <xf86drm.h>
+ #include <xf86drmMode.h>
+--
+Cheers,
+ Eric
+
diff --git a/0002-meson-install-drminfo-drmtest.patch b/0002-meson-install-drminfo-drmtest.patch
new file mode 100644
index 000000000000..7920fda04053
--- /dev/null
+++ b/0002-meson-install-drminfo-drmtest.patch
@@ -0,0 +1,37 @@
+From 5548568fc4419ece6e274344fdaaf3932d8a3522 Mon Sep 17 00:00:00 2001
+From: Eric Engestrom <eric.engestrom@imgtec.com>
+Date: Tue, 25 Apr 2017 11:40:27 +0100
+Subject: [PATCH drminfo 2/3] meson: install drminfo & drmtest
+
+`gtktest` had an explicit `install: false`, but it's the other way
+around: if unspecified, the file doesn't get installed; you have to
+explicitely ask for it with `install: true`.
+
+Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com>
+---
+ meson.build | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index 4722bf9..8312179 100644
+--- a/meson.build
++++ b/meson.build
+@@ -24,10 +24,12 @@ gtktest_deps = [ gtk3_dep,
+
+ executable('drminfo',
+ sources : drminfo_srcs,
+- dependencies : drminfo_deps)
++ dependencies : drminfo_deps,
++ install : true)
+ executable('drmtest',
+ sources : drmtest_srcs,
+- dependencies : drmtest_deps)
++ dependencies : drmtest_deps,
++ install : true)
+ executable('gtktest',
+ sources : gtktest_srcs,
+ dependencies : gtktest_deps,
+--
+Cheers,
+ Eric
+
diff --git a/0003-meson-install-drminfo-drmtest-man-pages.patch b/0003-meson-install-drminfo-drmtest-man-pages.patch
new file mode 100644
index 000000000000..66716f1ffc8f
--- /dev/null
+++ b/0003-meson-install-drminfo-drmtest-man-pages.patch
@@ -0,0 +1,53 @@
+From fb23a040798882fb64431d618e4957ec5c5487ea Mon Sep 17 00:00:00 2001
+From: Eric Engestrom <eric.engestrom@imgtec.com>
+Date: Tue, 25 Apr 2017 11:39:58 +0100
+Subject: [PATCH drminfo 3/3] meson: install drminfo & drmtest man-pages
+
+Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com>
+---
+ drminfo.man => drminfo.1 | 0
+ drminfo.spec | 4 ++--
+ drmtest.man => drmtest.1 | 0
+ meson.build | 3 +++
+ 4 files changed, 5 insertions(+), 2 deletions(-)
+ rename drminfo.man => drminfo.1 (100%)
+ rename drmtest.man => drmtest.1 (100%)
+
+diff --git a/drminfo.man b/drminfo.1
+similarity index 100%
+rename from drminfo.man
+rename to drminfo.1
+diff --git a/drminfo.spec b/drminfo.spec
+index f810a56..fa55ddd 100644
+--- a/drminfo.spec
++++ b/drminfo.spec
+@@ -33,8 +33,8 @@ install -d %{buildroot}%{_bindir}
+ install -d %{buildroot}%{_mandir}/man1
+ install drminfo %{buildroot}%{_bindir}/drminfo
+ install drmtest %{buildroot}%{_bindir}/drmtest
+-install -m644 drminfo.man %{buildroot}%{_mandir}/man1/drminfo.1
+-install -m644 drmtest.man %{buildroot}%{_mandir}/man1/drmtest.1
++install -m644 drminfo.1 %{buildroot}%{_mandir}/man1/drminfo.1
++install -m644 drmtest.1 %{buildroot}%{_mandir}/man1/drmtest.1
+
+ %files
+ %{_bindir}/drm*
+diff --git a/drmtest.man b/drmtest.1
+similarity index 100%
+rename from drmtest.man
+rename to drmtest.1
+diff --git a/meson.build b/meson.build
+index 8312179..95a5bd7 100644
+--- a/meson.build
++++ b/meson.build
+@@ -34,3 +34,6 @@ executable('gtktest',
+ sources : gtktest_srcs,
+ dependencies : gtktest_deps,
+ install : false)
++
++install_man('drminfo.1')
++install_man('drmtest.1')
+--
+Cheers,
+ Eric
+