summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Mazieres2020-12-21 23:03:00 -0800
committerDavid Mazieres2020-12-21 23:03:00 -0800
commit2cdc63ea1f80380d40f97ea8f174a51391adb59b (patch)
treeec32ffdb376c5b94ce311851889bb40186e853a5
downloadaur-2cdc63ea1f80380d40f97ea8f174a51391adb59b.tar.gz
initial version of droidcam-obs plugin package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--fix_Makefile.patch18
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd16f72a6956
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = droidcam-obs-plugin-git
+ pkgdesc = plugin for droidcam obs
+ pkgver = 1.1.r5.b8febd6
+ pkgrel = 1
+ url = https://dev47apps.com/obs/
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = libjpeg-turbo
+ makedepends = libusbmuxd
+ depends = obs-studio
+ provides = droidcam-obs-plugin
+ conflicts = droidcam-obs-plugin
+ source = droidcam-obs-plugin::git+https://github.com/dev47apps/droidcam-obs-plugin.git
+ source = fix_Makefile.patch
+ sha256sums = SKIP
+ sha256sums = 5a52749268fafe141eecbb63f0dea10ac1a100e1b1ba63a2f1cf574837b8c069
+
+pkgname = droidcam-obs-plugin-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..497d0e02dfaf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: David Mazieres (http://www.scs.stanford.edu/~dm/addr/)
+pkgname=droidcam-obs-plugin-git
+pkgver=1.1.r5.b8febd6
+pkgrel=1
+pkgdesc="plugin for droidcam obs"
+arch=(x86_64)
+url="https://dev47apps.com/obs/"
+srcurl="https://github.com/dev47apps/droidcam-obs-plugin.git"
+license=('GPL')
+groups=()
+depends=(obs-studio)
+makedepends=('git' 'libjpeg-turbo' 'libusbmuxd')
+optdepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+pkgstem=${pkgname%-git}
+source=("${pkgstem}::git+${srcurl}"
+ fix_Makefile.patch)
+noextract=()
+sha256sums=('SKIP'
+ '5a52749268fafe141eecbb63f0dea10ac1a100e1b1ba63a2f1cf574837b8c069')
+
+pkgver() {
+ cd "$srcdir/$pkgstem"
+ printf "%s" "$(git describe --tags --long | \
+ sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+prepare() {
+ cd "$srcdir/$pkgstem"
+ patch -p1 -i "$srcdir/fix_Makefile.patch"
+ mkdir -p build
+}
+
+build() {
+ cd "$srcdir/$pkgstem"
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/lib/obs-plugins"
+ cp "$srcdir/$pkgstem/build/droidcam-obs.so" \
+ "$pkgdir/usr/lib/obs-plugins/"
+ mkdir -p "$pkgdir/usr/share/obs/obs-plugins/droidcam-obs"
+ cp -r "$srcdir/$pkgstem/data/locale" \
+ "$pkgdir/usr/share/obs/obs-plugins/droidcam-obs/"
+}
diff --git a/fix_Makefile.patch b/fix_Makefile.patch
new file mode 100644
index 000000000000..45812658162e
--- /dev/null
+++ b/fix_Makefile.patch
@@ -0,0 +1,18 @@
+diff --git a/Makefile b/Makefile
+index 92c24d0..d10ab61 100644
+--- a/Makefile
++++ b/Makefile
+@@ -32,11 +32,11 @@ ifeq ($(UNAME),Linux)
+ JPEG_DIR ?= /opt/libjpeg-turbo
+ JPEG_LIB = $(JPEG_DIR)/lib$(shell getconf LONG_BIT)
+
+- STATIC += $(JPEG_LIB)/libturbojpeg.a
++ STATIC += /usr/lib/libturbojpeg.so
+ INCLUDES += -I$(JPEG_DIR)/include
+ INCLUDES += -I/usr/include/obs
+ LDD_LIBS += -lobs
+- LDD_LIBS += -lusbmuxd
++ LDD_LIBS += -lusbmuxd-2.0
+ LDD_FLAG += -shared
+
+ run: