summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Lopez2016-12-15 11:45:31 +0100
committerAdrian Lopez2016-12-15 11:45:31 +0100
commit103c1fe8a4b1b978b5656202a762540365d563a9 (patch)
tree1b981f6e06ad12fcb7efab8948b2378a28eff6f9
downloadaur-103c1fe8a4b1b978b5656202a762540365d563a9.tar.gz
newpkg: droidmote 3.0.0-1
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
-rw-r--r--droidmote.conf2
-rw-r--r--service13
5 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7da206e45f4e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = droidmote
+ pkgdesc = Server for DroidMote. Android, Windows and Linux from the comfort of your couch. Real Multi Touch without TouchScreen
+ pkgver = 3.0.0
+ pkgrel = 1
+ url = http://www.videomap.it/
+ arch = x86_64
+ license = unknown
+ backup = etc/droidmote.conf
+ source = https://github.com/adrianlzt/droidmote-aur/releases/download/3.0.0/droidmote
+ source = droidmote.conf
+ source = service
+ md5sums = 7f96c828660a6e844d4e5b3757eee198
+ md5sums = 13c6e42310e9be9b464a3b99149e06b0
+ md5sums = 83d4fbce1dd8dc2c51c89e480329b879
+
+pkgname = droidmote
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c81641bcc3f1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Adrian Lopez <adrianlzt@gmail.com>
+pkgname=droidmote
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="Server for DroidMote. Use your androd as remote mouse and keyboard."
+arch=("x86_64")
+url="http://www.videomap.it/"
+license=('unknown')
+depends=("libx11")
+backup=("etc/$pkgname.conf")
+source=("https://github.com/adrianlzt/${pkgname}-aur/releases/download/$pkgver/$pkgname"
+ "${pkgname}.conf"
+ "service")
+md5sums=('7f96c828660a6e844d4e5b3757eee198'
+ '13c6e42310e9be9b464a3b99149e06b0'
+ '83d4fbce1dd8dc2c51c89e480329b879')
+
+package() {
+ install -D ${pkgname} "${pkgdir}"/usr/bin/${pkgname}
+ install -Dm644 ${pkgname}.conf "${pkgdir}"/etc/${pkgname}.conf
+ install -Dm644 service "${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
+}
diff --git a/droidmote.conf b/droidmote.conf
new file mode 100644
index 000000000000..47e34f8802d7
--- /dev/null
+++ b/droidmote.conf
@@ -0,0 +1,2 @@
+PORT=2302
+PASSWORD=password
diff --git a/service b/service
new file mode 100644
index 000000000000..b581c55f35fa
--- /dev/null
+++ b/service
@@ -0,0 +1,13 @@
+[Unit]
+Description=DroidMote
+After=network.target
+
+[Service]
+Type=simple
+EnvironmentFile=/etc/droidmote.conf
+ExecStart=/usr/bin/droidmote $PORT $PASSWORD
+Restart=always
+
+[Install]
+WantedBy=multi-user.target
+