summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Lopez2016-12-15 13:06:50 +0100
committerAdrian Lopez2016-12-15 13:06:50 +0100
commit5dc875ec1f8ca02c73e15f097c1cb7a8d04a2ea4 (patch)
treec765327e69d208c146a170289f4623511c466a48
parent103c1fe8a4b1b978b5656202a762540365d563a9 (diff)
downloadaur-5dc875ec1f8ca02c73e15f097c1cb7a8d04a2ea4.tar.gz
Use original sources and sha256 sums
-rw-r--r--PKGBUILD34
1 files changed, 19 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c81641bcc3f1..3bdab57cc0ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,26 @@
# Maintainer: Adrian Lopez <adrianlzt@gmail.com>
+# Contributor: "Amhairghin" Oscar Garcia Amor (https://ogarcia.me)
+
pkgname=droidmote
pkgver=3.0.0
-pkgrel=1
-pkgdesc="Server for DroidMote. Use your androd as remote mouse and keyboard."
-arch=("x86_64")
-url="http://www.videomap.it/"
-license=('unknown')
-depends=("libx11")
-backup=("etc/$pkgname.conf")
-source=("https://github.com/adrianlzt/${pkgname}-aur/releases/download/$pkgver/$pkgname"
- "${pkgname}.conf"
+pkgrel=2
+pkgdesc='Server for DroidMote. Use your androd as remote mouse and keyboard.'
+arch=('i686' 'x86_64')
+url='http://www.videomap.it/'
+license=('custom:unknown')
+depends=('libx11')
+backup=("etc/${pkgname}.conf")
+source=("${pkgname}.conf"
"service")
-md5sums=('7f96c828660a6e844d4e5b3757eee198'
- '13c6e42310e9be9b464a3b99149e06b0'
- '83d4fbce1dd8dc2c51c89e480329b879')
+source_i686=("${pkgname}-x32-${pkgver}.tar::https://drive.google.com/uc?export=download&id=0B-EA_LjgyxcHRmFaZ0FKT3dpWFU")
+source_x86_64=("${pkgname}-x64-${pkgver}.tar::https://drive.google.com/uc?export=download&id=0B-EA_LjgyxcHOWhjejVfMzRsb0E")
+sha256sums=('b6386dec0977b27dff244e04f4fdbf5becc4c12731a261678524c21ffb3e53a4'
+ '0e88c9e0b189e0d8890ddbee8f00da13485973e028811e4e70a8b1c2b7595bbe')
+sha256sums_i686=('9f92ca81b6e7cd2fb24588b1d1ecb68790c760ae5f576e91222aecf0e484d6df')
+sha256sums_x86_64=('57ec9ed9eebe1c60869194259fa98938c6a2efc2756776b7fa0461028627a734')
package() {
- install -D ${pkgname} "${pkgdir}"/usr/bin/${pkgname}
- install -Dm644 ${pkgname}.conf "${pkgdir}"/etc/${pkgname}.conf
- install -Dm644 service "${pkgdir}"/usr/lib/systemd/system/${pkgname}.service
+ install -D "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}.conf" "${pkgdir}/etc/${pkgname}.conf"
+ install -Dm644 "service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
}