summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2019-01-31 19:55:22 +0800
committerChih-Hsuan Yen2019-01-31 19:55:22 +0800
commit77f803be11cab34f02762678de374fd7ee8f3a74 (patch)
tree5a4bb55d64ca0429ac3cb4303f6c41210b310bd7
parent3db0f6a542455992fb4d465279f28977c4244bdc (diff)
downloadaur-77f803be11cab34f02762678de374fd7ee8f3a74.tar.gz
store the icon locally (closes #35)
The only known way for now is to download a zip and extract it. However, Dropbox may use different zip parameters for the same forlder as reported in [1], and thus this temporary workaround. zipinfo for two versions of the zip file: Archive: dropbox-svg.zip Zip file size: 502 bytes, number of entries: 2 drwx--- 2.0 fat 0 b- stor 17-Sep-14 18:46 / -rw-a-- 2.0 fat 605 bl defN 17-Jul-21 22:12 DropboxGlyph_Blue.svg 2 files, 605 bytes uncompressed, 268 bytes compressed: 55.7% Archive: dropbox-svg-old.zip Zip file size: 502 bytes, number of entries: 2 ?rwxr--r-- 2.0 unx 0 b- stor 17-Sep-14 18:46 / ?rwxr--r-- 2.0 unx 605 bl defN 17-Jul-21 22:12 DropboxGlyph_Blue.svg 2 files, 605 bytes uncompressed, 268 bytes compressed: 55.7% [1] https://gitlab.com/yan12125/aur/issues/35
-rw-r--r--.SRCINFO4
-rw-r--r--DropboxGlyph_Blue.svg1
-rw-r--r--PKGBUILD9
3 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6bb33d7aed53..38dbf9bfbe7c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,12 +20,12 @@ pkgbase = dropbox
optdepends = perl-file-mimeinfo: opening dropbox folder on some desktop environments
optdepends = xdg-utils: for "Launch Dropbox Website" and file manager integration
options = !strip
- source = dropbox-svg.zip::https://www.dropbox.com/scl/fo/0eu2dsn07fy5k0gt5fy74/AABelaoobzsW8ZKJ2u9vnINGa/Glyph/Dropbox/SVG?dl=1
+ source = DropboxGlyph_Blue.svg
source = terms.txt
source = dropbox.service
source = dropbox@.service
validpgpkeys = 1C61A2656FB57B7E4DE0F4C1FC918B335044912E
- sha256sums = e53a2e006f7bd0421fec0b2d0eb31e88ca59bad7c9f640c4b126d462e674c3ed
+ sha256sums = 9ba76205ec5838db85d822f23cfd7e2112fd2757e8031d8374709f102143c548
sha256sums = 34605b2f36fe6b4bde9b858da3f73ac1505986af57be78bbb1c2c9cf1a611578
sha256sums = 6c67a9c8c95c08fafafd2f1d828074b13e3347b05d2e4f4bf4e62746115d7477
sha256sums = 98581e65a91ae1f19ed42edcdaaa52e102298b5da0d71b50089393d364474d3d
diff --git a/DropboxGlyph_Blue.svg b/DropboxGlyph_Blue.svg
new file mode 100644
index 000000000000..8c46b7f7abde
--- /dev/null
+++ b/DropboxGlyph_Blue.svg
@@ -0,0 +1 @@
+<svg id="Layer_1" data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 235.45 200"><defs><style>.cls-1{fill:#0061ff;}</style></defs><title>DropboxGlyph</title><polygon class="cls-1" points="58.86 0 0 37.5 58.86 75 117.73 37.5 58.86 0"/><polygon class="cls-1" points="176.59 0 117.73 37.5 176.59 75 235.45 37.5 176.59 0"/><polygon class="cls-1" points="0 112.5 58.86 150 117.73 112.5 58.86 75 0 112.5"/><polygon class="cls-1" points="176.59 75 117.73 112.5 176.59 150 235.45 112.5 176.59 75"/><polygon class="cls-1" points="58.86 162.5 117.73 200 176.59 162.5 117.73 125 58.86 162.5"/></svg> \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index d41962e78e55..154deb828ba8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -19,13 +19,14 @@ optdepends=(
)
options=('!strip')
-# The SVG link is retrieved from https://www.dropbox.com/branding
-source=("dropbox-svg.zip"::"https://www.dropbox.com/scl/fo/0eu2dsn07fy5k0gt5fy74/AABelaoobzsW8ZKJ2u9vnINGa/Glyph/Dropbox/SVG?dl=1"
- "terms.txt" "dropbox.service" "dropbox@.service")
+# DropboxGlyph_Blue.svg is downloaded from https://www.dropbox.com/scl/fo/0eu2dsn07fy5k0gt5fy74/AABelaoobzsW8ZKJ2u9vnINGa/Glyph/Dropbox/SVG,
+# and this folder is retrieved from https://www.dropbox.com/branding
+# TODO: find a way to download the icon directly from dropbox.com
+source=("DropboxGlyph_Blue.svg" "terms.txt" "dropbox.service" "dropbox@.service")
source_i686=("https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86-$pkgver.tar.gz"{,.asc})
source_x86_64=("https://clientupdates.dropboxstatic.com/dbx-releng/client/dropbox-lnx.x86_64-$pkgver.tar.gz"{,.asc})
-sha256sums=('e53a2e006f7bd0421fec0b2d0eb31e88ca59bad7c9f640c4b126d462e674c3ed'
+sha256sums=('9ba76205ec5838db85d822f23cfd7e2112fd2757e8031d8374709f102143c548'
'34605b2f36fe6b4bde9b858da3f73ac1505986af57be78bbb1c2c9cf1a611578'
'6c67a9c8c95c08fafafd2f1d828074b13e3347b05d2e4f4bf4e62746115d7477'
'98581e65a91ae1f19ed42edcdaaa52e102298b5da0d71b50089393d364474d3d')