summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Teichroeb2015-06-08 16:23:41 -0700
committerJoel Teichroeb2015-06-08 16:23:41 -0700
commite1d50cbe707a427910a444e769711af602e7e368 (patch)
tree0c3bc46b8857f11bf15c85bc1d873ee71b30978b
downloadaur-e1d50cbe707a427910a444e769711af602e7e368.tar.gz
Add dropbox-cli
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--dropbox-cli-arch.patch17
-rwxr-xr-xdropbox-cli.install4
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..02615091d026
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dropbox-cli
+ pkgdesc = Command line interface for dropbox
+ pkgver = 2.10.0
+ pkgrel = 4
+ url = http://www.dropbox.com
+ install = dropbox-cli.install
+ arch = any
+ license = GPL
+ makedepends = patch
+ depends = python2
+ depends = dropbox
+ source = https://linux.dropbox.com/packages/dropbox.py
+ source = dropbox-cli-arch.patch
+ md5sums = 50c2aefa89822bafd5f67d3678843dc3
+ md5sums = 0cb7114774490c31e7cc10f86692ac70
+
+pkgname = dropbox-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5507439135d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Joel Teichroeb <joel@teichroeb.net>
+# Contributor: Matthias Maennich < arch .at. maennich.net >
+# Contributor: bruce < b_a_g99 .at. hotmail.com >
+# Contributor: carstene1ns <arch carsten-teibes de>
+
+pkgname=dropbox-cli
+pkgver=2.10.0
+pkgrel=4
+pkgdesc='Command line interface for dropbox'
+arch=('any')
+url='http://www.dropbox.com'
+license=('GPL')
+install='dropbox-cli.install'
+depends=('python2' 'dropbox')
+makedepends=("patch")
+source=("https://linux.dropbox.com/packages/dropbox.py"
+ "$pkgname-arch.patch")
+md5sums=('50c2aefa89822bafd5f67d3678843dc3'
+ '0cb7114774490c31e7cc10f86692ac70')
+
+build(){
+ mkdir -p "$srcdir/build"
+ cp -L "$srcdir/dropbox.py" "$srcdir/build/"
+ cd "$srcdir/build"
+ patch -i "$srcdir/$pkgname-arch.patch"
+}
+
+package() {
+ install -D -m 755 "$srcdir/build/dropbox.py" "$pkgdir/usr/bin/dropbox-cli"
+}
diff --git a/dropbox-cli-arch.patch b/dropbox-cli-arch.patch
new file mode 100644
index 000000000000..002508fa781e
--- /dev/null
+++ b/dropbox-cli-arch.patch
@@ -0,0 +1,17 @@
+--- dropbox.py 2011-04-04 20:32:01.000000000 +0200
++++ dropbox.py 2011-04-28 22:55:17.976623103 +0200
+@@ -1,4 +1,4 @@
+-#!/usr/bin/python
++#!/usr/bin/python2
+ #
+ # Copyright 2008 Evenflow, Inc.
+ #
+@@ -610,6 +610,8 @@
+
+ def start_dropbox():
+ db_path = os.path.expanduser(u"~/.dropbox-dist/dropboxd").encode(sys.getfilesystemencoding())
++ if not os.path.exists(db_path):
++ db_path = u"/usr/bin/dropbox"
+ if os.access(db_path, os.X_OK):
+ f = open("/dev/null", "w")
+ # we don't reap the child because we're gonna die anyway, let init do it
diff --git a/dropbox-cli.install b/dropbox-cli.install
new file mode 100755
index 000000000000..5fa1389640a2
--- /dev/null
+++ b/dropbox-cli.install
@@ -0,0 +1,4 @@
+post_upgrade() {
+ echo "dropbox command renamed to dropbox-cli"
+}
+