summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGavin Lloyd2015-07-01 13:42:53 -0700
committerGavin Lloyd2015-07-01 13:42:53 -0700
commit43cc234c101630b8ed63bda164d7f4589243788c (patch)
treef34576d179f4454ae0b252cfe85780e9648a992f
downloadaur-43cc234c101630b8ed63bda164d7f4589243788c.tar.gz
Init commit
-rw-r--r--.SRCINFO30
-rw-r--r--PKGBUILD64
-rw-r--r--TERMS220
-rw-r--r--dropbox.desktop10
-rw-r--r--dropbox.pngbin0 -> 4996 bytes
-rw-r--r--dropbox.service13
-rw-r--r--dropbox@.service15
7 files changed, 352 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ea75fad16132
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,30 @@
+pkgbase = dropbox-gtk2
+ pkgdesc = A free service that lets you bring your photos, docs, and videos anywhere and share them easily (GTK2 version)
+ pkgver = 2.10.52
+ pkgrel = 1
+ url = https://www.dropbox.com/
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = dbus-glib
+ depends = gtk2
+ depends = libsm
+ provides = dropbox
+ conflicts = dropbox
+ conflicts = dropbox-experimental
+ options = !strip
+ options = !upx
+ source = dropbox.png
+ source = dropbox.desktop
+ source = dropbox.service
+ source = dropbox@.service
+ source = TERMS
+ source = https://dl.dropboxusercontent.com/u/17/dropbox-lnx.-2.10.52.tar.gz
+ sha1sums = 64073af76a2bbc7dba4a6886b82af0bb3e71a2a0
+ sha1sums = d5ad720762b9052a4fd6af839038318b37d5fd39
+ sha1sums = 169d929772ed3e74cdc68b948d69b44a1775db0c
+ sha1sums = 0019b370924494390b071ed6e607e5f70c88fc12
+ sha1sums = 46ba3146324c0ca0209ac76eaaddd74d9fec94ac
+
+pkgname = dropbox-gtk2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d96202451f0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Tom < tomgparchaur at gmail dot com >
+# Contributor: David Manouchehri <d@32t.ca>
+
+pkgname=dropbox-gtk2
+pkgver=2.10.52
+pkgrel=1
+pkgdesc='A free service that lets you bring your photos, docs, and videos anywhere and share them easily (GTK2 version)'
+arch=('i686' 'x86_64')
+url='https://www.dropbox.com/'
+license=('custom')
+depends=('dbus-glib' 'gtk2' 'libsm')
+provides=('dropbox')
+conflicts=('dropbox' 'dropbox-experimental')
+options=('!strip' '!upx')
+
+source=(
+ 'dropbox.png'
+ 'dropbox.desktop'
+ 'dropbox.service'
+ 'dropbox@.service'
+ 'TERMS'
+)
+
+sha1sums=(
+ '64073af76a2bbc7dba4a6886b82af0bb3e71a2a0'
+ 'd5ad720762b9052a4fd6af839038318b37d5fd39'
+ '169d929772ed3e74cdc68b948d69b44a1775db0c'
+ '0019b370924494390b071ed6e607e5f70c88fc12'
+ '46ba3146324c0ca0209ac76eaaddd74d9fec94ac'
+)
+
+if [ "${CARCH}" == 'i686' ]; then
+ _arch='x86'
+ sha1sums+=('8a600f3a1171d00ce15cbbf5ab1c35a2a8bd18eb')
+elif [ "${CARCH}" == 'x86_64' ]; then
+ _arch='x86_64'
+ sha1sums+=('0811b6f344e308a68b3c36421dc27f5db8948e15')
+fi
+
+source+=("https://dl.dropboxusercontent.com/u/17/dropbox-lnx.${_arch}-${pkgver}.tar.gz")
+
+package() {
+ install -d "${pkgdir}/opt"
+ cp -R "${srcdir}/.dropbox-dist/dropbox-lnx.${_arch}-${pkgver}" "${pkgdir}/opt/dropbox"
+
+ find "${pkgdir}/opt/dropbox/" -type f -exec chmod 644 {} \;
+ chmod 755 "${pkgdir}/opt/dropbox/dropboxd"
+ chmod 755 "${pkgdir}/opt/dropbox/dropbox"
+
+ install -d "${pkgdir}/usr/bin"
+ ln -s "/opt/dropbox/dropbox" "${pkgdir}/usr/bin/dropbox"
+ ln -s "/opt/dropbox/dropboxd" "${pkgdir}/usr/bin/dropboxd"
+
+ install -Dm644 "${srcdir}/dropbox.desktop" "${pkgdir}/usr/share/applications/dropbox.desktop"
+ install -Dm644 "${srcdir}/dropbox.png" "${pkgdir}/usr/share/pixmaps/dropbox.png"
+ install -Dm644 "${srcdir}/dropbox.service" "${pkgdir}/usr/lib/systemd/user/dropbox.service"
+ install -Dm644 "${srcdir}/dropbox@.service" "${pkgdir}/usr/lib/systemd/system/dropbox@.service"
+ install -Dm644 "${srcdir}/TERMS" "${pkgdir}/usr/share/licenses/$pkgname/TERMS"
+
+ rm -f "${pkgdir}/opt/dropbox/library.zip"
+ ln -s dropbox "${pkgdir}/opt/dropbox/library.zip"
+}
diff --git a/TERMS b/TERMS
new file mode 100644
index 000000000000..3c8b69e089aa
--- /dev/null
+++ b/TERMS
@@ -0,0 +1,220 @@
+Dropbox Terms of Service
+
+Posted: May 1, 2015
+
+Thanks for using Dropbox! These terms of service ("Terms") cover your use and
+access to our services, client software and websites ("Services"). If you reside
+outside of the United States of America, Canada and Mexico (“North America”)
+your agreement is with Dropbox Ireland, and if you reside in North America your
+agreement is with Dropbox, Inc. Our Privacy Policy explains how we collect and
+use your information while our Acceptable Use Policy outlines your
+responsibilities when using our Services. By using our Services, you're agreeing
+to be bound by these Terms, and to review our Privacy and Acceptable Use
+policies. If you're using our Services for an organization, you're agreeing to
+these Terms on behalf of that organization. Your Stuff & Your Permissions
+
+When you use our Services, you provide us with things like your files, content,
+email messages, contacts and so on ("Your Stuff"). Your Stuff is yours. These
+Terms don't give us any rights to Your Stuff except for the limited rights that
+enable us to offer the Services.
+
+We need your permission to do things like hosting Your Stuff, backing it up, and
+sharing it when you ask us to. Our Services also provide you with features like
+photo thumbnails, document previews, email organization, easy sorting, editing,
+sharing and searching. These and other features may require our systems to
+access, store and scan Your Stuff. You give us permission to do those things,
+and this permission extends to our affiliates and trusted third parties we work
+with. Sharing Your Stuff
+
+Our Services let you share Your Stuff with others, so please think carefully
+about what you share. Your Responsibilities
+
+You're responsible for your conduct, Your Stuff and you must comply with our
+Acceptable Use Policy. Content in the Services may be protected by others'
+intellectual property rights. Please don't copy, upload, download or share
+content unless you have the right to do so.
+
+We may review your conduct and content for compliance with these Terms and our
+Acceptable Use Policy. With that said, we have no obligation to do so. We aren't
+responsible for the content people post and share via the Services.
+
+Please safeguard your password to the Services, make sure that others don't have
+access to it, and keep your account information current.
+
+Finally, our Services are not intended for and may not be used by people under
+the age of 13. By using our Services, you are representing to us that you're
+over 13. Software
+
+Some of our Services allow you to download client software ("Software") which
+may update automatically. So long as you comply with these Terms, we give you a
+limited, nonexclusive, nontransferable, revocable license to use the Software,
+solely to access the Services. To the extent any component of the Software may
+be offered under an open source license, we'll make that license available to
+you and the provisions of that license may expressly override some of these
+Terms. Unless the following restrictions are prohibited by law, you agree not to
+reverse engineer or decompile the Services, attempt to do so, or assist anyone
+in doing so. Our Stuff
+
+The Services are protected by copyright, trademark, and other US and foreign
+laws. These Terms don't grant you any right, title or interest in the Services,
+others' content in the Services, Dropbox trademarks, logos and other brand
+features. We welcome feedback, but note that we may use comments or suggestions
+without any obligation to you. Copyright
+
+We respect the intellectual property of others and ask that you do too. We
+respond to notices of alleged copyright infringement if they comply with the
+law, and such notices should be reported using our Copyright Policy. We reserve
+the right to delete or disable content alleged to be infringing and terminate
+accounts of repeat infringers. Our designated agent for notice of alleged
+copyright infringement on the Services is:
+
+Copyright Agent Dropbox, Inc. 185 Berry Street, Suite 400 San Francisco, CA
+94107 copyright@dropbox.com Paid Accounts
+
+Billing. You can increase your storage space and add paid features to your
+account (turning your account into a "Paid Account"). We'll automatically bill
+you from the date you convert to a Paid Account and on each periodic renewal
+until cancellation. You're responsible for all applicable taxes, and we'll
+charge tax when required to do so.
+
+No Refunds. You may cancel your Dropbox Paid Account at any time but you won't
+be issued a refund unless it's legally required.
+
+Downgrades. Your Paid Account will remain in effect until it's cancelled or
+terminated under these Terms. If you don't pay for your Paid Account on time, we
+reserve the right to suspend it or reduce your storage to free space levels.
+
+Changes. We may change the fees in effect but will give you advance notice of
+these changes via a message to the email address associated with your account.
+Dropbox for Business
+
+Email address. If you sign up for a Dropbox account with an email address
+provisioned by your employer, your employer may be able to block your use of
+Dropbox until you transition to a Dropbox for Business account or you associate
+your Dropbox account with a personal email address.
+
+Using Dropbox for Business. If you join a Dropbox for Business account, you must
+use it in compliance with your employer's terms and policies. Please note that
+Dropbox for Business accounts are subject to your employer's control. Your
+administrators may be able to access, disclose, restrict, or remove information
+in or from your Dropbox for Business account. They may also be able to restrict
+or terminate your access to a Dropbox for Business account. If you convert an
+existing Dropbox account into a Dropbox for Business account, your
+administrators may prevent you from later disassociating your account from the
+Dropbox for Business account. Termination
+
+You're free to stop using our Services at any time. We also reserve the right to
+suspend or end the Services at any time at our discretion and without notice.
+For example, we may suspend or terminate your use of the Services if you're not
+complying with these Terms, or use the Services in a manner that would cause us
+legal liability, disrupt the Services or disrupt others' use of the Services.
+Except for Paid Accounts, we reserve the right to terminate and delete your
+account if you haven't accessed our Services for 12 consecutive months. We'll of
+course provide you with notice via the email address associated with your
+account before we do so. Services "AS IS"
+
+We strive to provide great Services, but there are certain things that we can't
+guarantee. TO THE FULLEST EXTENT PERMITTED BY LAW, DROPBOX AND ITS AFFILIATES,
+SUPPLIERS AND DISTRIBUTORS MAKE NO WARRANTIES, EITHER EXPRESS OR IMPLIED, ABOUT
+THE SERVICES. THE SERVICES ARE PROVIDED "AS IS." WE ALSO DISCLAIM ANY WARRANTIES
+OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. Some
+places don't allow the disclaimers in this paragraph, so they may not apply to
+you. Limitation of Liability
+
+TO THE FULLEST EXTENT PERMITTED BY LAW, EXCEPT FOR ANY LIABILITY FOR DROPBOX’S
+OR ITS AFFILIATES’ FRAUD, FRAUDULENT MISREPRESENTATION, OR GROSS NEGLIGENCE, IN
+NO EVENT WILL DROPBOX, ITS AFFILIATES, SUPPLIERS OR DISTRIBUTORS BE LIABLE FOR:
+
+(A) ANY INDIRECT, SPECIAL, INCIDENTAL, PUNITIVE, EXEMPLARY OR CONSEQUENTIAL
+DAMAGES, OR
+
+(B) ANY LOSS OF USE, DATA, BUSINESS, OR PROFITS, REGARDLESS OF LEGAL THEORY.
+
+THIS WILL BE REGARDLESS OF WHETHER OR NOT DROPBOX OR ANY OF ITS AFFILIATES HAS
+BEEN WARNED OF THE POSSIBILITY OF SUCH DAMAGES, AND EVEN IF A REMEDY FAILS OF
+ITS ESSENTIAL PURPOSE.
+
+ADDITIONALLY, DROPBOX, ITS AFFILIATES, SUPPLIERS AND DISTRIBUTORS WILL NOT BE
+LIABLE FOR AGGREGATE LIABILITY FOR ALL CLAIMS RELATING TO THE SERVICES FOR MORE
+THAN THE GREATER OF $20 OR THE AMOUNTS PAID BY YOU TO DROPBOX FOR THE PAST 12
+MONTHS OF THE SERVICES IN QUESTION.
+
+Some places don't allow the types of limitations in this paragraph, so they may
+not apply to you. Resolving Disputes
+
+Let's Try To Sort Things Out First. We want to address your concerns without
+needing a formal legal case. Before filing a claim against Dropbox, you agree to
+try to resolve the dispute informally by contacting dispute-notice@dropbox.com.
+We'll try to resolve the dispute informally by contacting you via email. If a
+dispute is not resolved within 15 days of submission, you or Dropbox may bring a
+formal proceeding.
+
+Judicial forum for disputes. You and Dropbox agree that any judicial proceeding
+to resolve claims relating to these Terms or the Services will be brought in the
+federal or state courts of San Francisco County, California, subject to the
+mandatory arbitration provisions below. Both you and Dropbox consent to venue
+and personal jurisdiction in such courts. IF YOU’RE A U.S. RESIDENT, YOU ALSO
+AGREE TO THE FOLLOWING MANDATORY ARBITRATION PROVISIONS:
+
+We Both Agree To Arbitrate. You and Dropbox agree to resolve any claims relating
+to these Terms or the Services through final and binding arbitration, except as
+set forth under Exceptions to Agreement to Arbitrate below.
+
+Opt-out of Agreement to Arbitrate. You can decline this agreement to arbitrate
+by clicking here and submitting the opt-out form within 30 days of first
+accepting these Terms.
+
+Arbitration Procedures. The American Arbitration Association (AAA) will
+administer the arbitration under its Commercial Arbitration Rules and the
+Supplementary Procedures for Consumer Related Disputes. The arbitration will be
+held in the United States county where you live or work, San Francisco (CA), or
+any other location we agree to.
+
+Arbitration Fees and Incentives. The AAA rules will govern payment of all
+arbitration fees. Dropbox will pay all arbitration fees for claims less than
+$75,000. If you receive an arbitration award that is more favorable than any
+offer we make to resolve the claim, we will pay you $1,000 in addition to the
+award. Dropbox will not seek its attorneys' fees and costs in arbitration unless
+the arbitrator determines that your claim is frivolous.
+
+Exceptions to Agreement to Arbitrate. Either you or Dropbox may assert claims,
+if they qualify, in small claims court in San Francisco (CA) or any United
+States county where you live or work. Either party may bring a lawsuit solely
+for injunctive relief to stop unauthorized use or abuse of the Services, or
+intellectual property infringement (for example, trademark, trade secret,
+copyright, or patent rights) without first engaging in arbitration or the
+informal dispute-resolution process described above. If the agreement to
+arbitrate is found not to apply to you or your claim, you agree to the exclusive
+jurisdiction of the state and federal courts in San Francisco County, California
+to resolve your claim.
+
+NO CLASS ACTIONS. You may only resolve disputes with us on an individual basis,
+and may not bring a claim as a plaintiff or a class member in a class,
+consolidated, or representative action. Class arbitrations, class actions,
+private attorney general actions, and consolidation with other arbitrations
+aren't allowed. Controlling Law
+
+These Terms will be governed by California law except for its conflicts of laws
+principles, unless otherwise required by a mandatory law of any other
+jurisdiction. Entire Agreement
+
+These Terms constitute the entire agreement between you and Dropbox with respect
+to the subject matter of these Terms, and supersede and replace any other prior
+or contemporaneous agreements, or terms and conditions applicable to the subject
+matter of these Terms. These Terms create no third party beneficiary rights.
+Waiver, Severability & Assignment
+
+Dropbox's failure to enforce a provision is not a waiver of its right to do so
+later. If a provision is found unenforceable, the remaining provisions of the
+Terms will remain in full effect and an enforceable term will be substituted
+reflecting our intent as closely as possible. You may not assign any of your
+rights under these Terms, and any such attempt will be void. Dropbox may assign
+its rights to any of its affiliates or subsidiaries, or to any successor in
+interest of any business associated with the Services. Modifications
+
+We may revise these Terms from time to time, and will always post the most
+current version on our website. If a revision meaningfully reduces your rights,
+we will notify you (by, for example, sending a message to the email address
+associated with your account, posting on our blog or on this page). By
+continuing to use or access the Services after the revisions come into effect,
+you agree to be bound by the revised Terms.
diff --git a/dropbox.desktop b/dropbox.desktop
new file mode 100644
index 000000000000..ddaec2d96429
--- /dev/null
+++ b/dropbox.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Dropbox
+GenericName=Network Storage
+Comment=Dropbox is a free service that lets you bring your photos, docs, and videos anywhere and share them easily
+Exec=dropboxd
+Icon=dropbox
+Terminal=false
+Type=Application
+Categories=Network;
+StartupNotify=false
diff --git a/dropbox.png b/dropbox.png
new file mode 100644
index 000000000000..e3a7682c0fe3
--- /dev/null
+++ b/dropbox.png
Binary files differ
diff --git a/dropbox.service b/dropbox.service
new file mode 100644
index 000000000000..4eaab115c80f
--- /dev/null
+++ b/dropbox.service
@@ -0,0 +1,13 @@
+[Unit]
+Description=Dropbox
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/dropboxd
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=on-failure
+
+[Install]
+WantedBy=default.target
+
diff --git a/dropbox@.service b/dropbox@.service
new file mode 100644
index 000000000000..fe19bded8dab
--- /dev/null
+++ b/dropbox@.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Dropbox
+After=local-fs.target network.target
+
+[Service]
+Type=simple
+ExecStart=/usr/bin/dropboxd
+ExecReload=/bin/kill -HUP $MAINPID
+KillMode=process
+Restart=on-failure
+User=%I
+
+[Install]
+WantedBy=multi-user.target
+