summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBjörn Bidar2015-06-13 18:19:34 +0200
committerBjörn Bidar2015-06-13 18:19:34 +0200
commitb39984e65213880f5d4e22992dedceb53fdafcb4 (patch)
tree5ca2cc4dca910e436622e9cf940e7742c48f22f4
downloadaur-b39984e65213880f5d4e22992dedceb53fdafcb4.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--use_python3.patch25
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e679e04bc049
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = dropbox-index
+ pkgdesc = Creates index.html for directory contents shared publicly on Dropbox. That way you can easily share whole content of the directory without the need to send separate links for all the shared files.
+ pkgver = 0.4.3
+ pkgrel = 4
+ url = http://code.google.com/p/kosciak-misc/wiki/DropboxIndex
+ arch = any
+ license = Apache
+ makedepends = subversion
+ depends = python
+ depends = dropbox
+ conflicts = dropbox-index-svn
+ source = use_python3.patch
+ source = http://pypi.python.org/packages/source/d/dropbox-index/dropbox-index-0.4.3.tar.gz
+ md5sums = 64c39149c591419d8cb0d98aa47fb840
+ md5sums = 17af3dc3983770287237f49551c98341
+
+pkgname = dropbox-index
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5042067b0429
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Thaodan <theodorstormgrade@gmail.com>
+# Contributor: Mike Redd <mredd@0tue0.com>
+
+pkgname=dropbox-index
+pkgver=0.4.3
+pkgrel=4
+pkgdesc="Creates index.html for directory contents shared publicly on Dropbox. That way you can easily share whole content of the directory without the need to send separate links for all the shared files. "
+arch=('any')
+url=('http://code.google.com/p/kosciak-misc/wiki/DropboxIndex')
+license=('Apache')
+depends=('python' 'dropbox')
+makedepends=('subversion')
+conflicts=('dropbox-index-svn')
+source=('use_python3.patch'
+ "http://pypi.python.org/packages/source/d/dropbox-index/dropbox-index-${pkgver}.tar.gz")
+md5sums=('64c39149c591419d8cb0d98aa47fb840'
+ '17af3dc3983770287237f49551c98341')
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ (
+ cd dropbox_index
+ patch -Np1 < ../../use_python3.patch
+ )
+ install -Ddm755 $pkgdir/usr/bin
+ install -Ddm755 $pkgdir/usr/lib/$pkgname
+ cp -r "icons/" "$pkgdir/usr/lib/$pkgname"
+ install -Dm655 template-example.html $pkgdir/usr/lib/$pkgname/template-example.html
+ install -Dm755 dropbox_index/__init__.py $pkgdir/usr/lib/$pkgname/__init__.py
+ # symlink to bin folder
+ ln -s /usr/lib/$pkgname/__init__.py $pkgdir/usr/bin/$pkgname
+}
diff --git a/use_python3.patch b/use_python3.patch
new file mode 100644
index 000000000000..b741d3df078a
--- /dev/null
+++ b/use_python3.patch
@@ -0,0 +1,25 @@
+--- a/ __init__.py
++++ b/__init__.py
+@@ -307,11 +307,11 @@
+
+ def crawl(path, back=None, recursive=False, template_file=None):
+ if not os.path.exists(path):
+- print 'ERROR: Path %s does not exists' % path
++ print('ERROR: Path %s does not exists' % path)
+ return
+
+ if not os.path.isdir(path):
+- print 'ERROR: Path %s is not a directory' % path
++ print('ERROR: Path %s is not a directory' % path)
+ return
+
+ # get contents of the directory
+@@ -334,7 +334,7 @@
+ # render directory contents
+ html_render(path, back, dirs, files, template_file)
+
+- print 'Created index.html for %s' % os.path.realpath(path)
++ print('Created index.html for %s' % os.path.realpath(path))
+
+ # crawl subdirectories
+ for dir in dirs: