summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlif Rachmawadi2017-03-12 22:41:31 +0700
committerAlif Rachmawadi2017-03-12 22:41:31 +0700
commit5bc60def572041671f1ff82aa97de76aa591c3ab (patch)
tree7b4d81ca4d9f4f4b86f0bce46a82aeb8ea4afa10
downloadaur-5bc60def572041671f1ff82aa97de76aa591c3ab.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD28
-rw-r--r--dropbox-light-icons.install11
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..350eb26249a7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dropbox-light-icons-git
+ pkgdesc = Dropbox light icons for dark panels
+ pkgver = 20170312
+ pkgrel = 1
+ url = https://github.com/subosito/dropbox-light-icons
+ install = dropbox-light-icons.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = hicolor-icon-theme
+ depends = dropbox
+ conflicts = dropbox-kfilebox-icons
+ conflicts = dropbox-plasma-light-icons-git
+ conflicts = dropbox-plasma-dark-icons-git
+ source = git://github.com/subosito/dropbox-light-icons.git
+ md5sums = SKIP
+
+pkgname = dropbox-light-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72bf5d6fe897
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Alif Rachmawadi <code@subosito.com>
+
+pkgname=dropbox-light-icons-git
+_pkgname=dropbox-light-icons
+pkgver=20170312
+pkgrel=1
+pkgdesc="Dropbox light icons for dark panels"
+arch=('any')
+url="https://github.com/subosito/dropbox-light-icons"
+license=('GPL')
+depends=('hicolor-icon-theme' 'dropbox')
+makedepends=('git')
+conflicts=('dropbox-kfilebox-icons'
+ 'dropbox-plasma-light-icons-git'
+ 'dropbox-plasma-dark-icons-git')
+source=(git://github.com/subosito/dropbox-light-icons.git)
+md5sums=(SKIP)
+install="dropbox-light-icons.install"
+
+pkgver(){
+ cd ${_pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package(){
+ install -d "${pkgdir}/usr/share/icons/hicolor/"
+ cp -r ${srcdir}/${_pkgname}/icons/* "${pkgdir}/usr/share/icons/hicolor/"
+}
diff --git a/dropbox-light-icons.install b/dropbox-light-icons.install
new file mode 100644
index 000000000000..6ec8d8eb1cfa
--- /dev/null
+++ b/dropbox-light-icons.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}