summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTete Plaza2016-10-08 15:12:10 -0300
committerTete Plaza2016-10-08 15:12:10 -0300
commitc296e5d3bc6d14e1e2a6fdd2ddf21b095d6c475d (patch)
tree6e555ae5c97f4d2c57fea744126d7bfa53af3780
downloadaur-c296e5d3bc6d14e1e2a6fdd2ddf21b095d6c475d.tar.gz
Initial files for Dropbox Plasma Dark Icons
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--dropbox-plasma-dark-icons.install11
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..96246c9c519c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dropbox-plasma-dark-icons-git
+ pkgdesc = Dropbox icons for Plasma 5 Dark Panels
+ pkgver = 20161008
+ pkgrel = 1
+ url = https://github.com/x11tete11x/dropbox-plasma-dark-icons
+ install = dropbox-plasma-dark-icons.install
+ arch = any
+ license = GPL
+ depends = hicolor-icon-theme
+ depends = dropbox
+ conflicts = dropbox-kfilebox-icons
+ conflicts = dropbox-plasma-light-icons-git
+ source = git://github.com/x11tete11x/dropbox-plasma-dark-icons.git
+ md5sums = SKIP
+
+pkgname = dropbox-plasma-dark-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4bdb17c1b9e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tete Plaza <11tete11@gmail.com>
+
+pkgname=dropbox-plasma-dark-icons-git
+_pkgname=dropbox-plasma-dark-icons
+pkgver=20161008
+pkgrel=1
+pkgdesc="Dropbox icons for Plasma 5 Dark Panels"
+arch=('any')
+url="https://github.com/x11tete11x/dropbox-plasma-dark-icons"
+license=('GPL')
+depends=('hicolor-icon-theme' 'dropbox')
+conflicts=('dropbox-kfilebox-icons'
+ 'dropbox-plasma-light-icons-git')
+source=(git://github.com/x11tete11x/dropbox-plasma-dark-icons.git)
+md5sums=(SKIP)
+install="dropbox-plasma-dark-icons.install"
+
+pkgver(){
+ cd ${_pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package(){
+ install -d "${pkgdir}/usr/share/icons/hicolor/"
+ cp -r ${srcdir}/${_pkgname}/icons/* "${pkgdir}/usr/share/icons/hicolor/"
+}
diff --git a/dropbox-plasma-dark-icons.install b/dropbox-plasma-dark-icons.install
new file mode 100644
index 000000000000..6ec8d8eb1cfa
--- /dev/null
+++ b/dropbox-plasma-dark-icons.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}