summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTete Plaza2016-10-08 15:15:57 -0300
committerTete Plaza2016-10-08 15:15:57 -0300
commitdf4dc99ddb89fec92dfbb3cc6e086ed664f6c903 (patch)
tree68e3d0059e29a5e85a640bd09b9ad225bd5db220
downloadaur-df4dc99ddb89fec92dfbb3cc6e086ed664f6c903.tar.gz
Initial files for Dropbox Plasma Light Icons
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD26
-rw-r--r--dropbox-plasma-light-icons.install11
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3baec9d2e5b6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = dropbox-plasma-light-icons-git
+ pkgdesc = Dropbox icons for Plasma 5 Light Panels
+ pkgver = 20161008
+ pkgrel = 1
+ url = https://github.com/x11tete11x/dropbox-plasma-light-icons
+ install = dropbox-plasma-light-icons.install
+ arch = any
+ license = GPL
+ depends = hicolor-icon-theme
+ depends = dropbox
+ conflicts = dropbox-kfilebox-icons
+ conflicts = dropbox-plasma-dark-icons-git
+ source = git://github.com/x11tete11x/dropbox-plasma-light-icons.git
+ md5sums = SKIP
+
+pkgname = dropbox-plasma-light-icons-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cce6b328dbe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Tete Plaza <11tete11@gmail.com>
+
+pkgname=dropbox-plasma-light-icons-git
+_pkgname=dropbox-plasma-light-icons
+pkgver=20161008
+pkgrel=1
+pkgdesc="Dropbox icons for Plasma 5 Light Panels"
+arch=('any')
+url="https://github.com/x11tete11x/dropbox-plasma-light-icons"
+license=('GPL')
+depends=('hicolor-icon-theme' 'dropbox')
+conflicts=('dropbox-kfilebox-icons'
+ 'dropbox-plasma-dark-icons-git')
+source=(git://github.com/x11tete11x/dropbox-plasma-light-icons.git)
+md5sums=(SKIP)
+install="dropbox-plasma-light-icons.install"
+
+pkgver(){
+ cd ${_pkgname}
+ git log -1 --format="%cd" --date=short | tr -d '-'
+}
+
+package(){
+ install -d "${pkgdir}/usr/share/icons/hicolor/"
+ cp -r ${srcdir}/${_pkgname}/icons/* "${pkgdir}/usr/share/icons/hicolor/"
+}
diff --git a/dropbox-plasma-light-icons.install b/dropbox-plasma-light-icons.install
new file mode 100644
index 000000000000..6ec8d8eb1cfa
--- /dev/null
+++ b/dropbox-plasma-light-icons.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -f /usr/share/icons/hicolor &> /dev/null
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}