summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2022-04-10 20:17:26 +0200
committerChristopher Arndt2022-04-10 20:17:26 +0200
commit9115fb649dbf8979cc056c28f23289616dde0d92 (patch)
tree4f318b106fab5742c90c225262e3211081cecd40
parentc497539ab42b72a254edfebb14e3818f3a5523cb (diff)
downloadaur-9115fb649dbf8979cc056c28f23289616dde0d92.tar.gz
Switch to compiling sfizz from git again
-rw-r--r--.SRCINFO40
-rw-r--r--.gitignore14
-rw-r--r--PKGBUILD86
-rw-r--r--drops-system-sfizz.patch33
4 files changed, 105 insertions, 68 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33b141c6aa6f..80cf0adb2e69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,56 @@
pkgbase = drops-git
pkgdesc = A sample player instrument LV2/VST2 plugin and stand-alone JACK program (git version)
- pkgver = 0.3.alpha.r35.g6aad2c2
+ pkgver = 1.0.beta.2.r0.g185cf4b
pkgrel = 1
url = https://github.com/clearly-broken-software/drops
arch = x86_64
- groups = pro-audio
groups = lv2-plugins
+ groups = pro-audio
groups = vst-plugins
license = GPL3
makedepends = git
makedepends = jack2
makedepends = libsndfile
- makedepends = mesa
- makedepends = sfizz
depends = gcc-libs
+ depends = libgl
+ depends = libglvnd
provides = drops
- provides = drops=0.3.alpha
+ provides = drops=1.0.beta.2
conflicts = drops
source = drops::git+https://github.com/clearly-broken-software/drops.git
source = dpf::git+https://github.com/DISTRHO/DPF.git
source = nanosvg::git+https://github.com/memononen/nanosvg.git
- source = drops-system-sfizz.patch
+ source = sfizz::git+https://github.com/sfztools/sfizz.git
+ source = abseil-cpp::git+https://github.com/abseil/abseil-cpp.git
+ source = vst3_base::git+https://github.com/steinbergmedia/vst3_base.git
+ source = vst3_pluginterfaces::git+https://github.com/steinbergmedia/vst3_pluginterfaces.git
+ source = vst3_public_sdk::git+https://github.com/steinbergmedia/vst3_public_sdk.git
+ source = vstgui4::git+https://github.com/sfztools/vstgui.git
+ source = dr_libs::git+https://github.com/mackron/dr_libs.git
+ source = stb_vorbis::git+https://github.com/sfztools/stb_vorbis.git
+ source = libaiff::git+https://github.com/sfztools/libaiff.git
+ source = sfzt_auwrapper::git+https://github.com/sfztools/sfzt_auwrapper.git
+ source = filesystem::git+https://github.com/gulrak/filesystem.git
+ source = simde::git+https://github.com/simd-everywhere/simde.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = b9be2ca33b9b7f322c34564659335fcd
pkgname = drops-git
depends = gcc-libs
+ depends = libgl
+ depends = libglvnd
depends = libjack.so
- depends = libsfizz.so
depends = libsndfile.so
-
diff --git a/.gitignore b/.gitignore
index 8d5b5fae27a6..cf02ec32353f 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,7 +1,21 @@
+abseil-cpp/
dpf/
+dr_libs/
drops/
drops-*.pkg.tar.xz
drops-*.pkg.tar.zst
+filesystem/
+libaiff/
nanosvg/
pkg/
+pkg/
+sfizz/
+sfzt_auwrapper/
+simde/
+src/
src/
+stb_vorbis/
+vst3_base/
+vst3_pluginterfaces/
+vst3_public_sdk/
+vstgui4/
diff --git a/PKGBUILD b/PKGBUILD
index 1b369e80094a..bac7a055c175 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,52 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
_pkgname=drops
-pkgname="${_pkgname}-git"
-pkgver=0.3.alpha.r35.g6aad2c2
+pkgname="$_pkgname-git"
+pkgver=1.0.beta.2.r0.g185cf4b
pkgrel=1
-pkgdesc="A sample player instrument LV2/VST2 plugin and stand-alone JACK program (git version)"
+pkgdesc='A sample player instrument LV2/VST2 plugin and stand-alone JACK program (git version)'
arch=('x86_64')
-url="https://github.com/clearly-broken-software/drops"
+url='https://github.com/clearly-broken-software/drops'
license=('GPL3')
-depends=('gcc-libs')
-makedepends=('git' 'jack2' 'libsndfile' 'mesa' 'sfizz')
-groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
-provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
-conflicts=("${_pkgname}")
+depends=(gcc-libs libgl libglvnd)
+makedepends=(git jack2 libsndfile)
+groups=(lv2-plugins pro-audio vst-plugins)
+provides=($_pkgname "$_pkgname=${pkgver//.r*/}")
+conflicts=($_pkgname)
source=("${_pkgname}::git+https://github.com/clearly-broken-software/${_pkgname}.git"
'dpf::git+https://github.com/DISTRHO/DPF.git'
'nanosvg::git+https://github.com/memononen/nanosvg.git'
- 'drops-system-sfizz.patch')
+ 'sfizz::git+https://github.com/sfztools/sfizz.git'
+ 'abseil-cpp::git+https://github.com/abseil/abseil-cpp.git'
+ 'vst3_base::git+https://github.com/steinbergmedia/vst3_base.git'
+ 'vst3_pluginterfaces::git+https://github.com/steinbergmedia/vst3_pluginterfaces.git'
+ 'vst3_public_sdk::git+https://github.com/steinbergmedia/vst3_public_sdk.git'
+ 'vstgui4::git+https://github.com/sfztools/vstgui.git'
+ 'dr_libs::git+https://github.com/mackron/dr_libs.git'
+ 'stb_vorbis::git+https://github.com/sfztools/stb_vorbis.git'
+ 'libaiff::git+https://github.com/sfztools/libaiff.git'
+ 'sfzt_auwrapper::git+https://github.com/sfztools/sfzt_auwrapper.git'
+ 'filesystem::git+https://github.com/gulrak/filesystem.git'
+ 'simde::git+https://github.com/simd-everywhere/simde.git'
+ )
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'b9be2ca33b9b7f322c34564659335fcd')
-
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
( set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
@@ -33,28 +55,40 @@ pkgver() {
}
prepare() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
- # Use system-installed sfizz library
git submodule init
- git submodule deinit sfizz
- git config submodule.dpf.url "${srcdir}/dpf"
- git config submodule.external.url "${srcdir}/nanosvg"
+ git config submodule.sfizz.url "$srcdir"/sfizz
+ git config submodule.dpf.url "$srcdir"/dpf
+ git config submodule.external.url "$srcdir"/nanosvg
git submodule update
- patch -N -r - -p 1 -i "${srcdir}"/drops-system-sfizz.patch || :
+ cd sfizz
+ git submodule init
+ git config submodule.external/abseil-cpp.url "$srcdir"/abseil-cpp
+ git config submodule.external/filesystem.url "$srcdir"/filesystem
+ git config submodule.external/simde.url "$srcdir"/simde
+ git config submodule.external/st_audiofile/thirdparty/dr_libs.url "$srcdir"/dr_libs
+ git config submodule.external/st_audiofile/thirdparty/libaiff.url "$srcdir"/libaiff
+ git config submodule.external/st_audiofile/thirdparty/stb_vorbis.url "$srcdir"/stb_vorbis
+ git config submodule.vst/external/sfzt_auwrapper.url "$srcdir"/sfzt_auwrapper
+ git config submodule.vst/external/VST_SDK/VST3_SDK/base.url "$srcdir"/vst3_base
+ git config submodule.vst/external/VST_SDK/VST3_SDK/pluginterfaces.url "$srcdir"/vst3_pluginterfaces
+ git config submodule.vst/external/VST_SDK/VST3_SDK/public.sdk.url "$srcdir"/vst3_public_sdk
+ git config submodule.vst/external/VST_SDK/VST3_SDK/vstgui4.url "$srcdir"/vstgui4
+ git submodule update
}
build() {
- cd "${srcdir}/${_pkgname}"
+ cd $_pkgname
make
}
package() {
- depends+=('libjack.so' 'libsfizz.so' 'libsndfile.so')
- cd "${srcdir}/${_pkgname}"
- install -s -vDm 755 bin/drops -t "${pkgdir}"/usr/bin
- install -vDm 644 bin/drops.lv2/*.ttl -t "${pkgdir}"/usr/lib/lv2/drops.lv2
- install -vDm 755 bin/drops.lv2/*.so -t "${pkgdir}"/usr/lib/lv2/drops.lv2
- install -vDm 755 bin/drops-vst.so -t "${pkgdir}"/usr/lib/vst
+ depends+=(libjack.so libsndfile.so)
+ cd $_pkgname
+ install -s -vDm 755 bin/drops -t "$pkgdir"/usr/bin
+ install -vDm 644 bin/drops.lv2/*.ttl -t "$pkgdir"/usr/lib/lv2/drops.lv2
+ install -vDm 755 bin/drops.lv2/*.so -t "$pkgdir"/usr/lib/lv2/drops.lv2
+ install -vDm 755 bin/drops-vst.so -t "$pkgdir"/usr/lib/vst
}
diff --git a/drops-system-sfizz.patch b/drops-system-sfizz.patch
deleted file mode 100644
index b1085b4431c9..000000000000
--- a/drops-system-sfizz.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 864c0d5..597f6b3 100644
---- a/Makefile
-+++ b/Makefile
-@@ -8,8 +8,6 @@ include dpf/Makefile.base.mk
-
-
- all: dgl plugins gen
--plugins: sfizz-lib
--include sfizz/dpf.mk
- # --------------------------------------------------------------
-
- dgl:
-diff --git a/plugins/drops/Makefile b/plugins/drops/Makefile
-index 651b4a0..0e930ec 100644
---- a/plugins/drops/Makefile
-+++ b/plugins/drops/Makefile
-@@ -57,13 +57,13 @@ FILES_UI = \
- # Do some magic
-
- include ../../dpf/Makefile.plugins.mk
--include ../../sfizz/dpf.mk
-
- # --------------------------------------------------------------
- # Extra flags
-+SFIZZ_C_FLAGS = $(shell $(PKG_CONFIG) --cflags sfizz)
- BUILD_C_FLAGS += $(SFIZZ_C_FLAGS)
--BUILD_CXX_FLAGS += $(SFIZZ_CXX_FLAGS)
--LINK_FLAGS += $(SFIZZ_LINK_FLAGS) $(shell $(PKG_CONFIG) --libs sndfile )
-+BUILD_CXX_FLAGS += $(SFIZZ_C_FLAGS)
-+LINK_FLAGS += $(shell $(PKG_CONFIG) --libs sfizz) $(shell $(PKG_CONFIG) --libs sndfile)
- BASE_FLAGS += -I. -I./widgets -I./external/src
- #LINK_FLAGS += $(shell pkg-config --libs sfizz)