summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2021-04-15 16:36:41 +0200
committerChristopher Arndt2021-04-15 16:36:41 +0200
commitc497539ab42b72a254edfebb14e3818f3a5523cb (patch)
tree936dd72e97c30fc52915ba086c1516e37a30d5e0
downloadaur-c497539ab42b72a254edfebb14e3818f3a5523cb.tar.gz
Add new VCS package 'drops-git'
Signed-off-by: Christopher Arndt <chris@chrisarndt.de>
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD60
-rw-r--r--drops-system-sfizz.patch33
4 files changed, 134 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..33b141c6aa6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = drops-git
+ pkgdesc = A sample player instrument LV2/VST2 plugin and stand-alone JACK program (git version)
+ pkgver = 0.3.alpha.r35.g6aad2c2
+ pkgrel = 1
+ url = https://github.com/clearly-broken-software/drops
+ arch = x86_64
+ groups = pro-audio
+ groups = lv2-plugins
+ groups = vst-plugins
+ license = GPL3
+ makedepends = git
+ makedepends = jack2
+ makedepends = libsndfile
+ makedepends = mesa
+ makedepends = sfizz
+ depends = gcc-libs
+ provides = drops
+ provides = drops=0.3.alpha
+ conflicts = drops
+ source = drops::git+https://github.com/clearly-broken-software/drops.git
+ source = dpf::git+https://github.com/DISTRHO/DPF.git
+ source = nanosvg::git+https://github.com/memononen/nanosvg.git
+ source = drops-system-sfizz.patch
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = b9be2ca33b9b7f322c34564659335fcd
+
+pkgname = drops-git
+ depends = gcc-libs
+ depends = libjack.so
+ depends = libsfizz.so
+ depends = libsndfile.so
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d5b5fae27a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+dpf/
+drops/
+drops-*.pkg.tar.xz
+drops-*.pkg.tar.zst
+nanosvg/
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1b369e80094a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
+
+_pkgname=drops
+pkgname="${_pkgname}-git"
+pkgver=0.3.alpha.r35.g6aad2c2
+pkgrel=1
+pkgdesc="A sample player instrument LV2/VST2 plugin and stand-alone JACK program (git version)"
+arch=('x86_64')
+url="https://github.com/clearly-broken-software/drops"
+license=('GPL3')
+depends=('gcc-libs')
+makedepends=('git' 'jack2' 'libsndfile' 'mesa' 'sfizz')
+groups=('pro-audio' 'lv2-plugins' 'vst-plugins')
+provides=("${_pkgname}" "${_pkgname}=${pkgver//.r*/}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/clearly-broken-software/${_pkgname}.git"
+ 'dpf::git+https://github.com/DISTRHO/DPF.git'
+ 'nanosvg::git+https://github.com/memononen/nanosvg.git'
+ 'drops-system-sfizz.patch')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'b9be2ca33b9b7f322c34564659335fcd')
+
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+
+ ( set -o pipefail
+ git describe --long --tags 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
+ echo "r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "${srcdir}/${_pkgname}"
+
+ # Use system-installed sfizz library
+ git submodule init
+ git submodule deinit sfizz
+ git config submodule.dpf.url "${srcdir}/dpf"
+ git config submodule.external.url "${srcdir}/nanosvg"
+ git submodule update
+
+ patch -N -r - -p 1 -i "${srcdir}"/drops-system-sfizz.patch || :
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ make
+}
+
+package() {
+ depends+=('libjack.so' 'libsfizz.so' 'libsndfile.so')
+ cd "${srcdir}/${_pkgname}"
+ install -s -vDm 755 bin/drops -t "${pkgdir}"/usr/bin
+ install -vDm 644 bin/drops.lv2/*.ttl -t "${pkgdir}"/usr/lib/lv2/drops.lv2
+ install -vDm 755 bin/drops.lv2/*.so -t "${pkgdir}"/usr/lib/lv2/drops.lv2
+ install -vDm 755 bin/drops-vst.so -t "${pkgdir}"/usr/lib/vst
+}
diff --git a/drops-system-sfizz.patch b/drops-system-sfizz.patch
new file mode 100644
index 000000000000..b1085b4431c9
--- /dev/null
+++ b/drops-system-sfizz.patch
@@ -0,0 +1,33 @@
+diff --git a/Makefile b/Makefile
+index 864c0d5..597f6b3 100644
+--- a/Makefile
++++ b/Makefile
+@@ -8,8 +8,6 @@ include dpf/Makefile.base.mk
+
+
+ all: dgl plugins gen
+-plugins: sfizz-lib
+-include sfizz/dpf.mk
+ # --------------------------------------------------------------
+
+ dgl:
+diff --git a/plugins/drops/Makefile b/plugins/drops/Makefile
+index 651b4a0..0e930ec 100644
+--- a/plugins/drops/Makefile
++++ b/plugins/drops/Makefile
+@@ -57,13 +57,13 @@ FILES_UI = \
+ # Do some magic
+
+ include ../../dpf/Makefile.plugins.mk
+-include ../../sfizz/dpf.mk
+
+ # --------------------------------------------------------------
+ # Extra flags
++SFIZZ_C_FLAGS = $(shell $(PKG_CONFIG) --cflags sfizz)
+ BUILD_C_FLAGS += $(SFIZZ_C_FLAGS)
+-BUILD_CXX_FLAGS += $(SFIZZ_CXX_FLAGS)
+-LINK_FLAGS += $(SFIZZ_LINK_FLAGS) $(shell $(PKG_CONFIG) --libs sndfile )
++BUILD_CXX_FLAGS += $(SFIZZ_C_FLAGS)
++LINK_FLAGS += $(shell $(PKG_CONFIG) --libs sfizz) $(shell $(PKG_CONFIG) --libs sndfile)
+ BASE_FLAGS += -I. -I./widgets -I./external/src
+ #LINK_FLAGS += $(shell pkg-config --libs sfizz)