summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordlawson2016-04-27 11:45:03 -0400
committerdlawson2016-04-27 11:45:03 -0400
commit20447c70a11831c616151087d3bfb3e88bd42335 (patch)
tree7789bac759666978116133818aaa69e6ffbfc75a
downloadaur-20447c70a11831c616151087d3bfb3e88bd42335.tar.gz
- Initial upload for Drozer 2.3.4.
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD50
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc4ff622984e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = drozer
+ pkgdesc = Comprehensive security and attack framework for Android
+ pkgver = 2.3.4
+ pkgrel = 2
+ url = https://labs.mwrinfosecurity.com/tools/drozer
+ arch = i686
+ arch = x86_64
+ license = bsd
+ depends = bash
+ depends = python2
+ depends = python2-protobuf
+ depends = python2-pyopenssl
+ depends = python2-twisted
+ provides = drozer
+ options = !strip
+ source_i686 = https://labs.mwrinfosecurity.com/system/assets/931/original/drozer_2.3.4.deb
+ depends_i686 = bash
+ depends_i686 = python2
+ depends_i686 = python2-protobuf
+ depends_i686 = python2-pyopenssl
+ depends_i686 = python2-twisted
+ md5sums_i686 = 901c7775fa2eb0e0c9943d380cf902a2
+ source_x86_64 = https://labs.mwrinfosecurity.com/system/assets/931/original/drozer_2.3.4.deb
+ md5sums_x86_64 = 901c7775fa2eb0e0c9943d380cf902a2
+
+pkgname = drozer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fee47292b9a5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Daniel Lawson <daniel dot lawson at mwrinfosecurity dot com>
+
+pkgname=drozer
+pkgver=2.3.4
+pkgrel=2
+pkgdesc='Comprehensive security and attack framework for Android'
+arch=('i686' 'x86_64')
+url='https://labs.mwrinfosecurity.com/tools/drozer'
+license=('bsd')
+options=('!strip')
+provides=('drozer')
+
+depends_x86_64=(
+ 'bash'
+ 'python2'
+ 'python2-protobuf'
+ 'python2-pyopenssl'
+ 'python2-twisted')
+depends_i686=(
+ 'bash'
+ 'python2'
+ 'python2-protobuf'
+ 'python2-pyopenssl'
+ 'python2-twisted')
+source_x86_64=("https://labs.mwrinfosecurity.com/system/assets/931/original/drozer_${pkgver}.deb")
+source_i686=("https://labs.mwrinfosecurity.com/system/assets/931/original/drozer_${pkgver}.deb")
+md5sums_x86_64=('901c7775fa2eb0e0c9943d380cf902a2')
+md5sums_i686=('901c7775fa2eb0e0c9943d380cf902a2')
+
+prepare() {
+ # Extract out data file
+ tar -xf data.tar.gz
+}
+
+package() {
+ # Bash completions get installed to a different location on Arch
+ mkdir -p "${pkgdir}"/usr/share/bash-completion/completions/
+ cp -dr --no-preserve=ownership etc/bash_completion.d/drozer "${pkgdir}"/usr/share/bash-completion/completions/
+
+ # Arch uses python3 by default, so we have to explicitly call python2
+ find . -type f -print0 | xargs -0 sed -i 's/\#\!\/usr\/bin\/python/\#\!\/usr\/bin\/python2/'
+
+ # Install rest of files
+ cp -dr --no-preserve=ownership usr/{bin,share} "${pkgdir}"/usr/
+ cp -dr --no-preserve=ownership usr/local/lib "${pkgdir}"/usr/
+
+
+
+
+}