summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:12:01 -0700
committerAaron DeVore2015-07-08 11:12:01 -0700
commitab9a29fc6f06e5df88b1fd913464c25f17b8692a (patch)
treedc0c373e480467ea3369b866271c88b0e1e90c61
downloadaur-ab9a29fc6f06e5df88b1fd913464c25f17b8692a.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD21
-rw-r--r--drpython.desktop8
-rw-r--r--drpython.sh3
4 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b934dcd993c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = drpython
+ pkgdesc = Python IDE built with wxWidgets
+ pkgver = 3.11.3
+ pkgrel = 2
+ url = http://drpython.sourceforge.net/
+ arch = any
+ license = GPL
+ depends = wxpython
+ optdepends = python2-docs: Python documentation
+ source = http://downloads.sourceforge.net/sourceforge/drpython/DrPython%20Current/3.11.3/DrPython_3.11.3.zip
+ source = drpython.sh
+ source = drpython.desktop
+ md5sums = eb59cf61d840af274d2940ce1a3c2bd4
+ md5sums = 4301f6421351e0632cf2d4f8f373616f
+ md5sums = 171d08cdc4f3cc429c60d70a5e4e5e3e
+
+pkgname = drpython
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7b52319eadf8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Contributor: Jordi Cerdan (jcerdan) <jcerdan@tecob.com>
+pkgname=drpython
+pkgver=3.11.3
+pkgrel=2
+pkgdesc="Python IDE built with wxWidgets"
+url="http://drpython.sourceforge.net/"
+license=('GPL')
+depends=('wxpython')
+optdepends=("python2-docs: Python documentation")
+arch=('any')
+source=("http://downloads.sourceforge.net/sourceforge/drpython/DrPython%20Current/$pkgver/DrPython_$pkgver.zip" 'drpython.sh' 'drpython.desktop')
+md5sums=('eb59cf61d840af274d2940ce1a3c2bd4' '4301f6421351e0632cf2d4f8f373616f' '171d08cdc4f3cc429c60d70a5e4e5e3e')
+
+package() {
+ mkdir -p $pkgdir/usr/share/$pkgname
+ cp -r $srcdir/DrPython/* $pkgdir/usr/share/$pkgname/
+ find $pkgdir -name "*.py" -exec \
+ sed -i '1s/python[[:space:]]*$/python2/' {} \;
+ install -D -m755 $srcdir/$pkgname.sh $pkgdir/usr/bin/$pkgname
+ install -D -m644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+}
diff --git a/drpython.desktop b/drpython.desktop
new file mode 100644
index 000000000000..e0fac1f9a4e3
--- /dev/null
+++ b/drpython.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=DrPython
+Exec=drpython
+Icon=/usr/share/drpython/bitmaps/drpython.png
+Terminal=false
+Type=Application
+Categories=Development
+StartupNotify=true
diff --git a/drpython.sh b/drpython.sh
new file mode 100644
index 000000000000..c5213c6ef944
--- /dev/null
+++ b/drpython.sh
@@ -0,0 +1,3 @@
+#/bin/bash
+
+python2 /usr/share/drpython/drpython.pyw