summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmin Vakil2021-03-20 18:25:28 +0330
committerAmin Vakil2021-03-20 18:25:28 +0330
commit8f74db08ff21e52393e54ee23fc56edeb3039a55 (patch)
tree43b4034b342af2c7befe42f7401304ff50f5d724
parent6b357182d7e08a055d703988743f4aefa3f654f7 (diff)
downloadaur-8f74db08ff21e52393e54ee23fc56edeb3039a55.tar.gz
remove magic and add source
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD31
2 files changed, 8 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 468f1a77268b..f24e2d39bcb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,8 @@ pkgbase = drupal8-git
license = GPL
makedepends = git
depends = php
+ source = git+https://git.drupalcode.org/project/drupal.git#branch=8.9.x
+ sha256sums = SKIP
pkgname = drupal8-git
diff --git a/PKGBUILD b/PKGBUILD
index dc33e61dfbe1..db473ef915d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
# Maintainer: Amin Vakil <info AT aminvakil DOT com>
# Contributor: realitygaps <realitygaps@yahoo.com>
+_pkgname=drupal8
pkgname=drupal8-git
pkgver=r38123.3bddf7fcb8
pkgrel=1
@@ -10,9 +11,8 @@ url="http://drupal.org"
license=('GPL')
makedepends=('git')
depends=('php')
-
-_gitroot="--branch 8.9.x http://git.drupal.org/project/drupal.git"
-_gitname="drupal8-git"
+source=('git+https://git.drupalcode.org/project/drupal.git#branch=8.9.x')
+sha256sums=('SKIP')
pkgver() {
cd "${srcdir}/${_pkgname}"
@@ -22,27 +22,8 @@ pkgver() {
}
package() {
- cd "$srcdir"
- echo "Connecting to GIT server...."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- echo "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
-
- echo "GIT checkout done or server timeout"
- echo "Starting make..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- #
- # BUILD HERE
- #
+ cd "${srcdir}/${_pkgname}"
mkdir -p $pkgdir/usr/share/webapps/drupal8-git
- cp -r $srcdir/drupal8-git/{*,.htaccess} $pkgdir/usr/share/webapps/drupal8-git
- echo "deny from all" > $pkgdir/usr/share/webapps/drupal8-git/.htaccess
+ cp -r ${srcdir}/${_pkgname}/drupal8-git/{*,.htaccess} ${pkgdir}/usr/share/webapps/drupal8-git
+ echo "deny from all" > ${pkgdir}/usr/share/webapps/drupal8-git/.htaccess
}