summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2016-10-06 15:10:49 +0200
committerStefan Auditor2016-10-06 15:10:49 +0200
commit98900e4e438c3f44d66c6a7f13b094f009a1e856 (patch)
tree5f5624269d6c2f7222adccd9bab5da16981759b6
parent632b60a9ac68828c0f35ece9becf1b0b88ab6dd1 (diff)
downloadaur-98900e4e438c3f44d66c6a7f13b094f009a1e856.tar.gz
Update to upstream version 1.0.0-rc1 pkgrel 2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e634ad0657cd..62d95bdf8be6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = drupalconsole
pkgdesc = The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation.
pkgver = 1.0.0_rc1
- pkgrel = 1
+ pkgrel = 2
url = http://drupalconsole.com/
install = drupalconsole.install
arch = any
@@ -10,8 +10,8 @@ pkgbase = drupalconsole
makedepends = php-composer
makedepends = git
depends = php
- source = drupalconsole::git+https://github.com/hechoendrupal/drupal-console-launcher.git
- sha512sums = SKIP
+ source = drupalconsole::https://github.com/hechoendrupal/drupal-console-launcher/archive/1.0.0-rc1.tar.gz
+ sha512sums = e4f9511b10b196056075e9d819dbd957fe10e10b18e8be940f91785f7e06c83791b25c9b526341752b6415ea3e4b8c80c0eb096f9ec1428f64d7f81229e29a43
pkgname = drupalconsole
diff --git a/PKGBUILD b/PKGBUILD
index 29709479b5ba..57ae798d2f61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=drupalconsole
pkgname=${_pkgname}
pkgver=1.0.0_rc1
-pkgrel=1
+pkgrel=2
pkgdesc="The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation."
arch=('any')
url="http://drupalconsole.com/"
@@ -12,16 +12,16 @@ license=('GPL')
depends=('php')
makedepends=("php-box" "php-composer" "git")
install="${_pkgname}.install"
-source=("${_pkgname}"::"git+https://github.com/hechoendrupal/drupal-console-launcher.git")
-sha512sums=('SKIP')
+source=("${_pkgname}"::"https://github.com/hechoendrupal/drupal-console-launcher/archive/${pkgver//_/-}.tar.gz")
+sha512sums=('e4f9511b10b196056075e9d819dbd957fe10e10b18e8be940f91785f7e06c83791b25c9b526341752b6415ea3e4b8c80c0eb096f9ec1428f64d7f81229e29a43')
build() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/drupal-console-launcher-${pkgver//_/-}"
php /usr/bin/composer install --no-dev
php -d phar.readonly=Off /usr/bin/php-box build
}
package() {
- cd "${srcdir}/${_pkgname}"
+ cd "${srcdir}/drupal-console-launcher-${pkgver//_/-}"
install -D -m755 "drupal.phar" "${pkgdir}/usr/bin/drupal"
}