summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2016-01-18 13:49:39 +0100
committerStefan Auditor2016-01-18 13:49:39 +0100
commit9ac62d87e49590ee9217eed66777f4b658c472f3 (patch)
treefcf01752d0f73d3d06e58df627005f31ebd2b9d8
downloadaur-9ac62d87e49590ee9217eed66777f4b658c472f3.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
-rw-r--r--drupalconsole.install3
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8d3fd43a2d1d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 12:45:49 UTC 2016
+pkgbase = drupalconsole
+ pkgdesc = The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation.
+ pkgver = 0.10.5
+ pkgrel = 1
+ url = http://drupalconsole.com/
+ install = drupalconsole.install
+ arch = any
+ license = GPL
+ makedepends = php-box
+ makedepends = php-composer
+ makedepends = git
+ depends = php
+ source = drupalconsole-0.10.5::git+https://github.com/hechoendrupal/DrupalConsole.git
+ sha512sums = SKIP
+
+pkgname = drupalconsole
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2e8164ba6c30
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Stefan Auditor <stefan.auditor@erdfisch.de>
+
+_pkgname=drupalconsole
+pkgname=${_pkgname}
+pkgver=0.10.5
+pkgrel=1
+pkgdesc="The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation."
+arch=('any')
+url="http://drupalconsole.com/"
+license=('GPL')
+depends=('php')
+makedepends=("php-box" "php-composer" "git")
+install=("${_pkgname}.install")
+source=("${_pkgname}-${pkgver}"::"git+https://github.com/hechoendrupal/DrupalConsole.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}-${pkgver}"
+ git describe --abbrev=0 --tags
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ulimit -n 3072
+ php /usr/bin/composer install --no-dev
+ php -d phar.readonly=Off /usr/bin/php-box build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -D -m755 "drupal.phar" "${pkgdir}/usr/bin/drupal"
+}
diff --git a/drupalconsole.install b/drupalconsole.install
new file mode 100644
index 000000000000..f4d043e8156d
--- /dev/null
+++ b/drupalconsole.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "Drupal Console installed as 'drupal'"
+}