summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2016-01-18 13:56:20 +0100
committerStefan Auditor2016-01-18 13:56:20 +0100
commit7730a578f75a8f529f3ef7f1cd3d59924490aabe (patch)
treed947ec4c6a17d30e411b96dce2ca8f98586ce386
parent35243c41577585ec9e3eab39758b0bf789464b4f (diff)
downloadaur-7730a578f75a8f529f3ef7f1cd3d59924490aabe.tar.gz
Refactor PKGBUILD to use box and compile a phar, fix license
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 24 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fea57fc494b0..61819761dd4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 18 12:35:54 UTC 2016
pkgbase = drupalconsole-git
pkgdesc = The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation.
- pkgver = 0.7.15.r81.g4e2a2b8
+ pkgver = 0.10.5.r12.geaeb48a
pkgrel = 1
url = http://drupalconsole.com/
install = drupalconsole.install
arch = any
- license = MIT
+ license = GPL
+ makedepends = php-box
+ makedepends = php-composer
+ makedepends = git
depends = php
- depends = php-composer
- provides = drupalconsole
- conflicts = drupalconsole
- source = drupalconsole-git::git+https://github.com/hechoendrupal/DrupalConsole.git
+ source = drupalconsole-0.10.5.r12.geaeb48a::git+https://github.com/hechoendrupal/DrupalConsole.git
sha512sums = SKIP
pkgname = drupalconsole-git
diff --git a/PKGBUILD b/PKGBUILD
index 1959d2cfd5e5..36c217da67ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,33 @@
# Maintainer: Victor Häggqvist <aur@snilius.com>
-# Contributor: Stean Auditor <stefan.auditor@erdfisch.de>
+# Contributor: Stefan Auditor <stefan.auditor@erdfisch.de>
_pkgname=drupalconsole
-pkgname=drupalconsole-git
-pkgver=0.9.4.r69.g671223d
+pkgname=${_pkgname}-git
+pkgver=0.10.5.r12.geaeb48a
pkgrel=1
pkgdesc="The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation."
-url="http://drupalconsole.com/"
-license=('MIT')
arch=('any')
-depends=('php' 'php-composer')
-provides=('drupalconsole')
-conflicts=('drupalconsole')
-source=($pkgname::git+https://github.com/hechoendrupal/DrupalConsole.git)
+url="http://drupalconsole.com/"
+license=('GPL')
+depends=('php')
+makedepends=("php-box" "php-composer" "git")
+install=("${_pkgname}.install")
+source=("${_pkgname}-${pkgver}"::"git+https://github.com/hechoendrupal/DrupalConsole.git")
sha512sums=('SKIP')
-install="$_pkgname.install"
pkgver() {
- cd "$pkgname"
+ cd "${_pkgname}-${pkgver}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
- composer install
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ulimit -n 3072
+ php /usr/bin/composer install --no-dev
+ php -d phar.readonly=Off /usr/bin/php-box build
}
package() {
- install -dm755 "$pkgdir/opt/$_pkgname/"
- cp -a "$srcdir/$pkgname/." "$pkgdir/opt/$_pkgname"
- install -dm755 "$pkgdir/usr/bin"
- ln -s "/opt/$_pkgname/bin/console" "$pkgdir/usr/bin/drupal"
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ install -D -m755 "drupal.phar" "${pkgdir}/usr/bin/drupal"
}
-
-# vim: ts=2 sts=2 sw=2 et ft=sh