summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2016-05-10 07:50:02 +0200
committerStefan Auditor2016-05-10 07:50:02 +0200
commitd184c5330fecf4831a45a373e88af628de4a09ea (patch)
treef5cff86f0236c3f13ad7a36e81b3d6f4956288af
parent593eb83be224e1f461e5f1317a162443f3169b95 (diff)
downloadaur-d184c5330fecf4831a45a373e88af628de4a09ea.tar.gz
Workaroung too many open files bug in gz
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53438bfa5299..b4ccfc58720a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Apr 5 09:37:34 UTC 2016
pkgbase = drupalconsole-git
pkgdesc = The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation.
- pkgver = 0.10.12.r53.gbc01b5d
+ pkgver = 1.0.0.alpha2.r42.g35370d5
pkgrel = 1
url = http://drupalconsole.com/
install = drupalconsole.install
@@ -12,7 +10,7 @@ pkgbase = drupalconsole-git
makedepends = php-composer
makedepends = git
depends = php
- provides = drupalconsole=0.10.12.r53.gbc01b5d
+ provides = drupalconsole=1.0.0.alpha2.r42.g35370d5
conflicts = drupalconsole
source = drupalconsole::git+https://github.com/hechoendrupal/DrupalConsole.git
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index e738cee3756c..b3a82602fc6e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=drupalconsole
pkgname=${_pkgname}-git
-pkgver=0.10.12.r53.gbc01b5d
+pkgver=1.0.0.alpha2.r42.g35370d5
pkgrel=1
pkgdesc="The Drupal Console is a suite of tools that you run on a command line interface (CLI) to generate boilerplate code and interact with a Drupal 8 installation."
arch=('any')
@@ -25,7 +25,12 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
- ulimit -n 4096
+
+ # Increase open files limit to be able to compress the phar contents
+ # ulimit -n 4096
+ # Remove the compression option from configuration
+ sed -i '/compression/d' box.json
+
php /usr/bin/composer install --no-dev
php -d phar.readonly=Off /usr/bin/php-box build
}