summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrealitygaps2015-07-06 16:50:34 +0200
committerrealitygaps2015-07-06 16:50:34 +0200
commit4710226646dce4b4dee6e4a1381121b22ff8baa6 (patch)
tree4305394c424d123a8030abcd3cc794636bfc8144
downloadaur-4710226646dce4b4dee6e4a1381121b22ff8baa6.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD44
-rw-r--r--drush.install12
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3b1e25c33b6c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = drush
+ pkgdesc = The Drupal command-line shell
+ pkgver = 6.6.0
+ pkgrel = 1
+ url = http://github.com/drush-ops/drush/
+ install = drush.install
+ arch = any
+ license = GPL
+ depends = php
+ depends = bash
+ source = http://github.com/drush-ops/drush/archive/6.6.0.tar.gz
+ source = http://download.pear.php.net/package/Console_Table-1.1.3.tgz
+ md5sums = bfe556917f29e2d3c25dda8ecde96281
+ md5sums = 34b5f34db1ab0c4daedf2862958af257
+
+pkgname = drush
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2a5b343751d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Josh 'jheretic' King <josh at chambana dot net>
+# Contributor: James An <james@jamesan.ca>
+
+pkgname=drush
+pkgver=6.6.0
+pkgrel=1
+pkgdesc="The Drupal command-line shell"
+arch=('any')
+url="http://github.com/drush-ops/drush/"
+license=('GPL')
+depends=('php' 'bash')
+install=${pkgname}.install
+source=(
+ "http://github.com/drush-ops/$pkgname/archive/$pkgver.tar.gz"
+ 'http://download.pear.php.net/package/Console_Table-1.1.3.tgz'
+)
+md5sums=('bfe556917f29e2d3c25dda8ecde96281'
+ '34b5f34db1ab0c4daedf2862958af257')
+
+
+package() {
+ cd "${pkgname}-${pkgver}"
+
+ # create dir structure
+ install -d "${pkgdir}/etc/${pkgname}"
+ install -d "${pkgdir}/usr/bin"
+ install -d "${pkgdir}/usr/lib/${pkgname}"
+ install -d "${pkgdir}/usr/share/doc/${pkgname}"
+ # add empty directory for drush extensions
+ install -d "${pkgdir}/usr/share/${pkgname}/commands"
+
+ # install main files
+ cp -r commands classes includes "${pkgdir}/usr/lib/${pkgname}"
+ cp -r examples "${pkgdir}/usr/share/doc/${pkgname}"
+
+ install -m644 examples/example.{{aliases.,}drushrc.php,drush.ini} "${pkgdir}/etc/${pkgname}"
+ install -m644 drush_logo-black.png "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 drush.info docs/drush.api.php "${pkgdir}/usr/lib/${pkgname}"
+ install -m755 drush.php drush "${pkgdir}/usr/lib/${pkgname}"
+ ln -s "/usr/lib/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # install Console_Table library too
+ install -Dm755 ../Console_Table-1.1.3/Table.php "${pkgdir}/usr/lib/${pkgname}/includes/table.inc"
+}
diff --git a/drush.install b/drush.install
new file mode 100644
index 000000000000..d60c97e2522f
--- /dev/null
+++ b/drush.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo "-----------------"
+ echo "Drush is meant to be run from the root directory of your Drupal "
+ echo "install by default. Look at /usr/share/doc/drush/ for the "
+ echo "README, as well as an example drushrc.php config and example "
+ echo "plugin."
+ echo "-----------------"
+ echo "Additionally, if your php.ini settings are too restrictive, "
+ echo "you may have to override some of the settings using drush.ini "
+ echo "in either your home directory (~/.drush.ini) or in "
+ echo "/etc/drush/drush.ini for system-wide changes."
+}