summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Leggiero2015-10-30 12:46:56 +0000
committerEduardo Leggiero2015-10-30 12:46:56 +0000
commitba1c34262e4cd4d844ff7d646a5137fadbd9492a (patch)
treed59b25703554c263e8ad5b20b6d984851aff0e44
parent6891aa1018a23657fa6303a2a1dd328885db5530 (diff)
downloadaur-ba1c34262e4cd4d844ff7d646a5137fadbd9492a.tar.gz
updated to drush 7.1.0
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD23
-rw-r--r--drush.install15
4 files changed, 32 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b1e25c33b6c..6d6f01a3d59a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = drush
- pkgdesc = The Drupal command-line shell
- pkgver = 6.6.0
+ pkgdesc = Drush is a command line shell and Unix scripting interface for Drupal
+ pkgver = 7.1.0
pkgrel = 1
- url = http://github.com/drush-ops/drush/
+ url = https://github.com/drush-ops/drush/
install = drush.install
arch = any
license = GPL
depends = php
- depends = bash
- source = http://github.com/drush-ops/drush/archive/6.6.0.tar.gz
- source = http://download.pear.php.net/package/Console_Table-1.1.3.tgz
- md5sums = bfe556917f29e2d3c25dda8ecde96281
- md5sums = 34b5f34db1ab0c4daedf2862958af257
+ depends = php-composer
+ source = http://github.com/drush-ops/drush/archive/7.1.0.tar.gz
+ source = http://download.pear.php.net/package/Console_Table-1.2.1.tgz
+ md5sums = edbcac3216b793b5debb4a4b7c7bac12
+ md5sums = 87e0447d69f396eb755c3a8629a9d8d9
pkgname = drush
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6e1208c67ca1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg/
+/src/
+/*.gz
+/*.pkg.tar.xz
+/*.tgz
diff --git a/PKGBUILD b/PKGBUILD
index a05c3c92609a..249754f6df2c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,26 @@
# Contributor: James An <james@jamesan.ca>
pkgname=drush
-pkgver=6.6.0
+pkgver=7.1.0
pkgrel=1
-pkgdesc="The Drupal command-line shell"
+pkgdesc="Drush is a command line shell and Unix scripting interface for Drupal"
arch=('any')
-url="http://github.com/drush-ops/drush/"
+url="https://github.com/drush-ops/drush/"
license=('GPL')
-depends=('php' 'bash')
+depends=('php' 'php-composer')
install=${pkgname}.install
source=(
"http://github.com/drush-ops/$pkgname/archive/$pkgver.tar.gz"
- 'http://download.pear.php.net/package/Console_Table-1.1.3.tgz'
+ 'http://download.pear.php.net/package/Console_Table-1.2.1.tgz'
)
-md5sums=('bfe556917f29e2d3c25dda8ecde96281'
- '34b5f34db1ab0c4daedf2862958af257')
-
+md5sums=('edbcac3216b793b5debb4a4b7c7bac12'
+ '87e0447d69f396eb755c3a8629a9d8d9')
package() {
cd "${pkgname}-${pkgver}"
+ composer update
+
# create dir structure
install -d "${pkgdir}/etc/${pkgname}"
install -d "${pkgdir}/usr/bin"
@@ -31,15 +32,15 @@ package() {
install -d "${pkgdir}/usr/share/${pkgname}/commands"
# install main files
- cp -r commands classes includes "${pkgdir}/usr/lib/${pkgname}"
+ cp -r commands lib includes vendor "${pkgdir}/usr/lib/${pkgname}"
cp -r examples "${pkgdir}/usr/share/doc/${pkgname}"
install -m644 examples/example.{{aliases.,}drushrc.php,drush.ini} "${pkgdir}/etc/${pkgname}"
install -m644 drush_logo-black.png "${pkgdir}/usr/share/doc/${pkgname}"
- install -m644 drush.info docs/drush.api.php "${pkgdir}/usr/lib/${pkgname}"
+ install -m644 drush.info drush.api.php "${pkgdir}/usr/lib/${pkgname}"
install -m755 drush.php drush "${pkgdir}/usr/lib/${pkgname}"
ln -s "/usr/lib/${pkgname}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
# install Console_Table library too
- install -Dm755 ../Console_Table-1.1.3/Table.php "${pkgdir}/usr/lib/${pkgname}/includes/table.inc"
+ install -Dm644 ../Console_Table-1.2.1/Table.php "${pkgdir}/usr/lib/${pkgname}/includes/table.inc"
}
diff --git a/drush.install b/drush.install
index d60c97e2522f..360de0df587b 100644
--- a/drush.install
+++ b/drush.install
@@ -1,12 +1,11 @@
post_install() {
- echo "-----------------"
+ echo "---------------------------------------------------------------- "
echo "Drush is meant to be run from the root directory of your Drupal "
- echo "install by default. Look at /usr/share/doc/drush/ for the "
- echo "README, as well as an example drushrc.php config and example "
- echo "plugin."
- echo "-----------------"
+ echo "install by default. Look at /usr/share/doc/drush/ for an example "
+ echo "drushrc.php config and example plugin."
+ echo "---------------------------------------------------------------- "
echo "Additionally, if your php.ini settings are too restrictive, "
- echo "you may have to override some of the settings using drush.ini "
- echo "in either your home directory (~/.drush.ini) or in "
- echo "/etc/drush/drush.ini for system-wide changes."
+ echo "you may have to override some of the settings using drush.ini "
+ echo "in either your home directory (~/.drush.ini) or in "
+ echo "/etc/drush/drush.ini for system-wide changes."
}