summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-07-04 18:49:34 -0400
committerJames An2016-07-04 18:49:34 -0400
commit931d09908723404da436ebc54109e975a66c4432 (patch)
tree8870a3dbdc8c4ebebaa882edd6735eb745bad100
downloadaur-drush-config-extra-git.tar.gz
Initial commit with working spec.
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD40
3 files changed, 83 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..83f73c2d7eb4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = drush-config-extra-git
+ pkgdesc = Additional configuration management Drush commands for Drupal, notably config-merge.
+ pkgver = 1.0.1.r1.ga6942ba
+ pkgrel = 1
+ url = https://github.com/drush-ops/config-extra
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = drush
+ provides = drush-config-extra=1.0.1.r1.ga6942ba
+ conflicts = drush-config-extra
+ source = config-extra::git+https://github.com/drush-ops/config-extra.git
+ md5sums = SKIP
+
+pkgname = drush-config-extra-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e1cc0b510fd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=drush-config-extra-git
+_pkgname=${pkgname%-git}
+__pkgname=${_pkgname#drush-}
+pkgver=1.0.1.r1.ga6942ba
+pkgrel=1
+pkgdesc='Additional configuration management Drush commands for Drupal, notably config-merge.'
+arch=('any')
+url="https://github.com/drush-ops/$__pkgname"
+license=('GPL')
+depends=('drush')
+makedepends=('git')
+provides=("$_pkgname=$pkgver")
+conflicts=("$_pkgname")
+source=("$__pkgname"::"git+https://github.com/drush-ops/$__pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$__pkgname"
+ (
+ set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ ) 2>/dev/null
+}
+
+prepare() {
+ cd "$__pkgname"
+
+ composer --no-interaction update --prefer-source --no-dev --no-autoloader
+}
+
+package() {
+ cd "$__pkgname"
+
+ path="$pkgdir/usr/share/webapps/drush/commands/$__pkgname"
+ install -dm755 "$path"
+ cp -a * "$path"
+}