summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2014-10-07 18:27:52 -0400
committerJames An2014-10-07 18:27:52 -0400
commit2eea001225d5d59a91c466241834dc68f74d7eb0 (patch)
tree1c7f00d65bb11caee21bb163d04a264d12e41736
parent8165670de7d3785c281889f09422541e99e005f0 (diff)
downloadaur-2eea001225d5d59a91c466241834dc68f74d7eb0.tar.gz
Fixed drush-git pkgver() and dependencies.
-rw-r--r--PKGBUILD10
-rw-r--r--drush-git.install2
2 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 042784cbcd89..f76d59efaac6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,14 @@
# Maintainer: Tess 'socketwench' Flynn <tess@deninet.com>
pkgname=drush-git
-pkgver=6.0.0.r500.gbf45cb4
+pkgver=7.0.0.alpha5.r34.g7928b9b
pkgrel=1
pkgdesc="The Drupal command-line shell, git version."
arch=('any')
url="https://github.com/drush-ops/drush"
license=('GPL')
-depends=('php' 'bash' 'php-composer')
+depends=('bash' 'php-composer')
+provides=('drush')
conflicts=('drush5' 'drush')
install=${pkgname}.install
source=("$pkgname"::'git://github.com/drush-ops/drush.git')
@@ -19,11 +20,10 @@ md5sums=('SKIP')
pkgver() {
cd $pkgname
- git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
}
package() {
@@ -66,4 +66,6 @@ package() {
ln -s /usr/share/webapps/drush/drush ${pkgdir}/usr/bin/drush
#Make directory for eventual packaged drush extensions
#mkdir -p ${pkgdir}/usr/share/webapps/drush/commands
+
+ composer install -d ${pkgdir}/usr/share/webapps/drush
}
diff --git a/drush-git.install b/drush-git.install
index 9848b118cd49..73d5176bc4e6 100644
--- a/drush-git.install
+++ b/drush-git.install
@@ -1,6 +1,4 @@
post_install() {
- cd /usr/share/webapps/drush
- composer install
echo "-----------------"
echo "Drush is meant to be run from the root directory of your Drupal "
echo "install by default. Look at /usr/share/doc/drush/ for the "