summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2015-11-11 15:11:41 -0500
committerJames An2015-11-11 15:11:41 -0500
commit4053d2a698e727cb688739c69f6b815206531e67 (patch)
treec4f1a5b25814befad84c57507d5b6d610727af6e
parent0a8a512913252191e40307c3a2f67874d0515e7a (diff)
downloadaur-4053d2a698e727cb688739c69f6b815206531e67.tar.gz
Removed forced shared system-wide drush config and added a drush clear cache command after every install/update.
-rw-r--r--PKGBUILD2
-rw-r--r--drush-git.install10
2 files changed, 1 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cbd73c99e435..275d66f78ed5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -60,8 +60,6 @@ package() {
install --directory "$pkgdir/etc/bash_completion.d"
install --directory --owner=http --group=http --mode=6775 "$pkgdir/etc/$_pkgname"{,/cache{,/{default,download,usage}}}
install --owner=http --group=http --mode=644 "$_pkgname.ini" "$pkgdir/etc/$_pkgname/$_pkgname.ini"
- install --directory "$pkgdir/etc/skel"
- ln --force --symbolic "/etc/$_pkgname" "$pkgdir/etc/skel/.$_pkgname"
install --directory "$pkgdir/usr/bin"
install --directory "$pkgdir/usr/share/webapps/$_pkgname"
install --directory "$pkgdir/usr/share/doc/$_pkgname/misc"
diff --git a/drush-git.install b/drush-git.install
index 9de9447e1608..0ea45388ec33 100644
--- a/drush-git.install
+++ b/drush-git.install
@@ -3,13 +3,5 @@ post_install() {
}
post_upgrade() {
- echo '>>> Setting up shared system-wide drush configuration'
- echo ' by symlinking ~/.drush to /etc/drush for all users.'
- for user in $(cut --fields=1,6 --delimiter=: /etc/passwd | grep :/home); do
- user=($(echo $user | tr ':' ' '))
- path="${user[1]}/.drush"
- user="${user[0]}"
- [ -h "$path" -a "$(realpath "$path")" = /etc/drush ] ||
- sudo -Hu $user ln --backup --force --symbolic /etc/drush "$path"
- done
+ drush cache-clear drush
}