summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-12-14 11:36:48 -0500
committerJames An2016-12-14 11:36:48 -0500
commit5dcfa6369d3ac566a9764a920d008c069dd8080c (patch)
tree2b75f98fbf21c4766b341bab9833f5ff4df488b1
parentc80fc5d4d3ec7dca2314500cd05f95a4e2a0cdb3 (diff)
downloadaur-5dcfa6369d3ac566a9764a920d008c069dd8080c.tar.gz
Added doc option so drush help commands work, and downgraded to Drush 8.x as Drush 9.x drops support for Drupal 7 with its OOP requirements.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD26
2 files changed, 17 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 02e45d6b8a61..a7692d3e7289 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = drush-git
pkgdesc = The Drupal command-line shell, git version.
- pkgver = 9.0.0.alpha1.r230.g4d0ca6c
+ pkgver = 8.1.8
pkgrel = 1
url = http://drush.org
install = drush-git.install
@@ -11,10 +11,11 @@ pkgbase = drush-git
depends = php-composer
depends = php-gd
optdepends = bash-completion
- provides = drush=9.0.0.alpha1.r230.g4d0ca6c
+ provides = drush=8.1.8
conflicts = drush
+ options = docs
options = emptydirs
- source = drush::git+https://github.com/drush-ops/drush.git#branch=master
+ source = drush::git+https://github.com/drush-ops/drush.git#tag=8.1.8
source = php.ini
md5sums = SKIP
md5sums = 9627e7e568fa7933fe32b44ad21b219f
diff --git a/PKGBUILD b/PKGBUILD
index 7e861f0742e5..826136b9dbe9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=drush-git
_pkgname=${pkgname%-git}
-pkgver=9.0.0.alpha1.r230.g4d0ca6c
+pkgver=8.1.8
pkgrel=1
pkgdesc='The Drupal command-line shell, git version.'
arch=('any')
@@ -15,21 +15,21 @@ optdepends=('bash-completion')
#~ checkdepends=('bzr' 'sqlite')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-options=(emptydirs)
+options=(docs emptydirs)
install=$pkgname.install
-source=("$_pkgname"::"git+https://github.com/$_pkgname-ops/$_pkgname.git#branch=master"
+source=("$_pkgname"::"git+https://github.com/$_pkgname-ops/$_pkgname.git#tag=$pkgver"
"php.ini")
md5sums=('SKIP'
'9627e7e568fa7933fe32b44ad21b219f')
-pkgver() {
- cd "$_pkgname"
- (
- set -o pipefail
- git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- ) 2>/dev/null
-}
+#~ pkgver() {
+ #~ cd "$_pkgname"
+ #~ (
+ #~ set -o pipefail
+ #~ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ #~ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ #~ ) 2>/dev/null
+#~ }
prepare() {
cd "$_pkgname"
@@ -74,6 +74,6 @@ package() {
# Symlink upstream's hard-coded drush base path
#~ ln -s "/usr/share/webapps/$_pkgname" "$pkgdir/usr/share/$_pkgname"
- install -Dm644 "examples/example.aliases.${_pkgname}rc.php" "${pkgdir}/etc/$_pkgname/aliases.${_pkgname}rc.php"
- install -Dm644 "examples/example.${_pkgname}rc.php" "${pkgdir}/etc/$_pkgname/${_pkgname}rc.php"
+ install -Dm644 -o http -g http "examples/example.aliases.${_pkgname}rc.php" "${pkgdir}/etc/$_pkgname/aliases.${_pkgname}rc.php"
+ install -Dm644 -o http -g http "examples/example.${_pkgname}rc.php" "${pkgdir}/etc/$_pkgname/${_pkgname}rc.php"
}