summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2016-03-13 23:52:34 -0400
committerJames An2016-03-13 23:52:34 -0400
commitd3de4a28b6fa2ea2b7313365e891c4454c18e337 (patch)
tree849c9a13c0a94f5b99b6cf057d04979a0547fcac
parent40846035a14ec2afbb1aba1d0065b2dcce27a2bf (diff)
downloadaur-d3de4a28b6fa2ea2b7313365e891c4454c18e337.tar.gz
Added build commands to generate PHAR, install commands for example configuration files, and bumped upstream version.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD59
-rw-r--r--php.ini20
3 files changed, 62 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b939e6b37370..fb6c9c6cccb8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,24 @@
# Generated by mksrcinfo v8
-# Tue Dec 8 19:19:35 UTC 2015
+# Mon Mar 14 03:50:26 UTC 2016
pkgbase = drush-git
pkgdesc = The Drupal command-line shell, git version.
- pkgver = 8.0.0.r64.gc7e08f7
+ pkgver = 9.0.0.alpha1.r1.gb96621d
pkgrel = 1
- url = https://github.com/drush-ops/drush-git
+ url = http://drush.org
install = drush-git.install
arch = any
license = GPL
makedepends = git
+ makedepends = php-box
depends = bash
depends = php-composer
depends = php-gd
- provides = drush=8.0.0.r64.gc7e08f7
+ provides = drush=9.0.0.alpha1.r1.gb96621d
conflicts = drush
- source = drush::git+https://github.com/drush-ops/drush.git
- source = req.drush.ini
+ source = drush::git+https://github.com/drush-ops/drush.git#branch=master
+ source = php.ini
md5sums = SKIP
- md5sums = fd34300a8ce7ca8e826cb8b9a5ed2b89
+ md5sums = 938cbe5548e3381e63668ea865ad7aa1
pkgname = drush-git
diff --git a/PKGBUILD b/PKGBUILD
index d83516390b11..985b4ee65471 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,23 @@
# Maintainer: James An <james@jamesan.ca>
# Contributor: Tess 'socketwench' Flynn <tess@deninet.com>
-_pkgname=drush
-pkgname=$_pkgname-git
-pkgver=8.0.0.r64.gc7e08f7
+pkgname=drush-git
+_pkgname=${pkgname%-git}
+pkgver=9.0.0.alpha1.r1.gb96621d
pkgrel=1
pkgdesc='The Drupal command-line shell, git version.'
arch=('any')
-url="https://github.com/drush-ops/$pkgname"
+url="http://$_pkgname.org"
license=('GPL')
depends=('bash' 'php-composer' 'php-gd')
-makedepends=('git')
+makedepends=('git' 'php-box')
provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
install=$pkgname.install
-source=("$_pkgname"::"git+https://github.com/drush-ops/$_pkgname.git"
- "req.$_pkgname.ini")
+source=("$_pkgname"::"git+https://github.com/$_pkgname-ops/$_pkgname.git#branch=master"
+ "php.ini")
md5sums=('SKIP'
- 'fd34300a8ce7ca8e826cb8b9a5ed2b89')
+ '938cbe5548e3381e63668ea865ad7aa1')
pkgver() {
cd "$_pkgname"
@@ -29,38 +29,42 @@ pkgver() {
}
prepare() {
- composer update --prefer-source --no-interaction --working-dir "$_pkgname"
- composer install --prefer-source --no-interaction --working-dir "$_pkgname"
- for extension in gd mysqli pdo_mysql; do
- echo "extension=$extension.so" >| "$extension.$_pkgname.ini"
- done
- sed -r 's/^([^;$])/;\1/' "$_pkgname/examples/example.$_pkgname.ini" >| "$_pkgname.ini"
+ composer --no-interaction --working-dir="$_pkgname" install --prefer-source
+
+ # Generate empty drush.ini from the example by
+ # commenting out all line starting with word character.
+ sed 's/^\b/;/' "$_pkgname/examples/example.$_pkgname.ini" >| "$_pkgname.ini"
+}
+
+build() {
+ cd "$_pkgname"
+
+ php -d phar.readonly=Off /usr/bin/php-box build
}
check() {
cd "$_pkgname"
- #~ msg2 'Testing on Drupal 6'
- #~ UNISH_DRUPAL_MAJOR_VERSION=6 ./unish.sh
- #~ msg2 'Testing on Drupal 7'
- #~ UNISH_DRUPAL_MAJOR_VERSION=7 ./unish.sh
- #~ msg2 'Testing on Drupal 8'
- #~ UNISH_DRUPAL_MAJOR_VERSION=8 ./unish.sh
+ msg2 'Verifying PHAR file'
+ php -d phar.readonly=Off /usr/bin/php-box verify $_pkgname.phar
+
+ msg2 'Testing on Drupal 6'
+ UNISH_DRUPAL_MAJOR_VERSION=6 ./unish.sh
+ msg2 'Testing on Drupal 7'
+ UNISH_DRUPAL_MAJOR_VERSION=7 ./unish.sh
+ msg2 'Testing on Drupal 8'
+ UNISH_DRUPAL_MAJOR_VERSION=8 ./unish.sh
}
package() {
- # Install PHP configuration files
- for conf in gd mysqli pdo_mysql req; do
- install -Dm644 "$conf.$_pkgname.ini" "$pkgdir/etc/php/conf.d/$conf.$_pkgname.ini"
- done
# Set up directory structure
- install --directory "$pkgdir/etc/bash_completion.d"
install --owner=http --group=http --mode=6775 --directory "$pkgdir/etc/drush"
install --owner=http --group=http --mode=644 "$_pkgname.ini" "$pkgdir/etc/$_pkgname/$_pkgname.ini"
install --directory "$pkgdir/usr/bin"
install --directory "$pkgdir/usr/share/webapps/$_pkgname"
install --directory "$pkgdir/usr/share/doc/$_pkgname/misc"
+ install -Dm644 php.ini "$pkgdir/etc/php/conf.d/$_pkgname.ini"
# Copy main application files
cd "$_pkgname"
@@ -69,4 +73,9 @@ package() {
rm -rf "$pkgdir/usr/share/doc/$_pkgname/"{CONTRIBUTING.md,README.md,docs,examples,misc/windrush_build}
ln -s "/usr/share/webapps/$_pkgname/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
ln -s "/usr/share/webapps/$_pkgname/$_pkgname.complete.sh" "$pkgdir/etc/bash_completion.d"
+
+ install -Dm644 "$_pkgname.complete.sh" "$pkgdir/usr/share/bash-completion/completions/$_pkgname"
+ install -Dm644 "examples/example.$_pkgname.ini" "${pkgdir}/etc/$_pkgname/$_pkgname.ini"
+ install -Dm644 "examples/example.aliases.${_pkgname}rc.php" "${pkgdir}/etc/$_pkgname/aliases.${_pkgname}rc.php"
+ install -Dm644 "examples/example.${_pkgname}rc.php" "${pkgdir}/etc/$_pkgname/${_pkgname}rc.php"
}
diff --git a/php.ini b/php.ini
new file mode 100644
index 000000000000..2c390c3e7938
--- /dev/null
+++ b/php.ini
@@ -0,0 +1,20 @@
+; Required extensions
+;extension=gd.so
+;extension=mysqli.so
+;extension=pdo_mysql.so
+
+; Drupal requirements.
+;date.timezone = UTC
+;memory_limit = 192M
+;open_basedir =
+
+; Recommended settings.
+;display_errors = stderr
+;error_reporting = E_ALL
+
+; Uncomment to enable opcache (recommended)
+;zend_extension=opcache.so
+;[opcache]
+;opcache.enable=0
+;opcache.enable_cli=0
+