summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Auditor2016-01-22 09:48:18 +0100
committerStefan Auditor2016-01-22 09:48:18 +0100
commitfb42672af333d12211d30aff85aadb3771dcb92e (patch)
treefcc4bc15073161e5a2dcbc5b228ed354d165a306
parent5e226576f6ce5bc269d6106680a5a58134e62736 (diff)
downloadaur-fb42672af333d12211d30aff85aadb3771dcb92e.tar.gz
Change checkout paths
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 69da83be61f5..e9a8865ae2a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sat Jan 16 14:03:09 UTC 2016
+# Fri Jan 22 08:47:25 UTC 2016
pkgbase = drush-git-alternative
pkgdesc = Drush is a command line shell and Unix scripting interface for Drupal
pkgver = 8.0.2.r14.g30f88b2
@@ -13,7 +13,7 @@ pkgbase = drush-git-alternative
depends = php
provides = drush=8.0.2.r14.g30f88b2
conflicts = drush
- source = drush-8.0.2.r14.g30f88b2::git+https://github.com/drush-ops/drush.git
+ source = drush::git+https://github.com/drush-ops/drush.git
sha512sums = SKIP
pkgname = drush-git-alternative
diff --git a/PKGBUILD b/PKGBUILD
index 6e04f643fb9a..55c0429370d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,23 +12,23 @@ depends=('php')
makedepends=("php-box" "php-composer" "git")
provides=("${_pkgname}=${pkgver}")
conflicts=("${_pkgname}")
-source=("${_pkgname}-${pkgver}"::"git+https://github.com/drush-ops/drush.git")
+source=("${_pkgname}"::"git+https://github.com/drush-ops/drush.git")
sha512sums=('SKIP')
pkgver() {
- cd "${_pkgname}-${pkgver}"
+ cd "${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}"
php /usr/bin/composer install --no-dev
cp box.json.dist box.json
php -d phar.readonly=Off /usr/bin/php-box build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}"
install -D -m755 "${_pkgname}.phar" "${pkgdir}/usr/bin/${_pkgname}"
install -D -m644 "examples/example.aliases.drushrc.php" "${pkgdir}/etc/drush/aliases.drushrc.php"
install -D -m644 "examples/example.drush.ini" "${pkgdir}/etc/drush/drush.ini"