summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2024-01-05 19:14:45 +0100
committerMarcell Meszaros2024-01-05 19:14:45 +0100
commit68de97473cf97cbc5c3edfeffda45246df64b7d7 (patch)
tree47a4519dde5503b78920d72d85f7d4ab695ddaa4
parent9c65d000a3e661c071e612535bf01c172e1d2fb2 (diff)
downloadaur-68de97473cf97cbc5c3edfeffda45246df64b7d7.tar.gz
fix package
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore31
-rw-r--r--PKGBUILD14
3 files changed, 25 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 22914202819e..da1708b8f8fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = drush-launcher-git
pkgdesc = A small wrapper around Drush for your global $PATH.
- pkgver = 0.5.1.r1.gace4b71
+ pkgver = 0.10.2.r1.gb168e45
pkgrel = 1
url = https://github.com/drush-ops/drush-launcher
arch = any
license = GPL
+ makedepends = composer
makedepends = git
makedepends = php-box
- depends = php-composer
+ depends = php
provides = drush
- provides = drush-launcher=0.5.1.r1.gace4b71
+ provides = drush-launcher=0.10.2.r1.gb168e45
conflicts = drush
conflicts = drush-launcher
source = drush-launcher::git+https://github.com/drush-ops/drush-launcher.git
- md5sums = SKIP
+ b2sums = SKIP
pkgname = drush-launcher-git
-
diff --git a/.gitignore b/.gitignore
index 43316bc3c124..c20489312365 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,27 +1,22 @@
-# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
-
+# based on https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
*.tar
*.tar.*
+*.rpm
+*.jar
+*.exe
+*.msi
*.zip
*.tgz
-*.log
-*.log.*
-*.sig
-
-# makepkg working folders
-pkg
-src
-
-#
-# Additional ignore patterns:
-#
-
-# Source files
*.deb
*.gem
*.out
-*.rpm
*.html
+*.log
+*.log.*
+*.sig
-# Ignore package source folders
-*/*
+*/
+*.orig
+*.bak
+*.backup
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
index 4d44275dbb95..641f4da31815 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
-# Maintainer: James An <james@jamesan.ca>
+# Contributor: James An <james@jamesan.ca>
pkgname=drush-launcher-git
_pkgname=${pkgname%-git}
__pkgname=${_pkgname%-launcher}
-pkgver=0.5.1.r1.gace4b71
+pkgver=0.10.2.r1.gb168e45
pkgrel=1
pkgdesc='A small wrapper around Drush for your global $PATH.'
arch=('any')
url="https://github.com/drush-ops/drush-launcher"
license=('GPL')
-depends=('php-composer')
-makedepends=('git' 'php-box')
-provides=("$__pkgname" "$_pkgname=$pkgver")
+depends=('php')
+makedepends=('composer' 'git' 'php-box')
+provides=("$__pkgname=${pkgver%.r*}" "$_pkgname=${pkgver%.r*}")
conflicts=("$__pkgname" "$_pkgname")
source=("$_pkgname"::"git+https://github.com/$__pkgname-ops/$_pkgname.git")
-md5sums=('SKIP')
+b2sums=('SKIP')
pkgver() {
cd "$_pkgname"
@@ -33,7 +33,7 @@ prepare() {
build() {
cd "$_pkgname"
- php -d phar.readonly=Off /usr/bin/php-box build
+ php -d phar.readonly=Off /usr/bin/box compile
}
package() {