summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames An2018-02-16 14:07:45 -0500
committerJames An2018-02-16 14:07:45 -0500
commit9c65d000a3e661c071e612535bf01c172e1d2fb2 (patch)
treeba7e334f3594a89ed1e3f4ea5ca70f54011a9d5f
downloadaur-9c65d000a3e661c071e612535bf01c172e1d2fb2.tar.gz
Initial commit with working PKGBUILD.
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore27
-rw-r--r--PKGBUILD43
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22914202819e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = drush-launcher-git
+ pkgdesc = A small wrapper around Drush for your global $PATH.
+ pkgver = 0.5.1.r1.gace4b71
+ pkgrel = 1
+ url = https://github.com/drush-ops/drush-launcher
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = php-box
+ depends = php-composer
+ provides = drush
+ provides = drush-launcher=0.5.1.r1.gace4b71
+ conflicts = drush
+ conflicts = drush-launcher
+ source = drush-launcher::git+https://github.com/drush-ops/drush-launcher.git
+ md5sums = SKIP
+
+pkgname = drush-launcher-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..43316bc3c124
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,27 @@
+# From: https://github.com/github/gitignore/blob/master/ArchLinuxPackages.gitignore
+
+*.tar
+*.tar.*
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+# makepkg working folders
+pkg
+src
+
+#
+# Additional ignore patterns:
+#
+
+# Source files
+*.deb
+*.gem
+*.out
+*.rpm
+*.html
+
+# Ignore package source folders
+*/*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d44275dbb95
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: James An <james@jamesan.ca>
+
+pkgname=drush-launcher-git
+_pkgname=${pkgname%-git}
+__pkgname=${_pkgname%-launcher}
+pkgver=0.5.1.r1.gace4b71
+pkgrel=1
+pkgdesc='A small wrapper around Drush for your global $PATH.'
+arch=('any')
+url="https://github.com/drush-ops/drush-launcher"
+license=('GPL')
+depends=('php-composer')
+makedepends=('git' 'php-box')
+provides=("$__pkgname" "$_pkgname=$pkgver")
+conflicts=("$__pkgname" "$_pkgname")
+source=("$_pkgname"::"git+https://github.com/$__pkgname-ops/$_pkgname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ ( set -o pipefail
+ git describe --long --tag | sed -r 's/([^-]*-g)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ ) 2>/dev/null
+}
+
+prepare() {
+ cd "$_pkgname"
+
+ composer --no-interaction install --prefer-source
+}
+
+build() {
+ cd "$_pkgname"
+
+ php -d phar.readonly=Off /usr/bin/php-box build
+}
+
+package() {
+ cd "$_pkgname"
+
+ install -Dm755 "$__pkgname.phar" "$pkgdir/usr/bin/$__pkgname"
+}