summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Kühn2017-02-08 11:49:15 +0100
committerDanilo Kühn2017-02-08 11:49:15 +0100
commit6b0ba6a595d99c4d842c2f715dda2aff7694bfda (patch)
tree47395cf818fbaaa24ba2b8d3a5bacc4758606688
downloadaur-6b0ba6a595d99c4d842c2f715dda2aff7694bfda.tar.gz
add dry-bin version 0.6-5
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..017595067b37
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dry-bin
+ pkgdesc = dry is a terminal application to manage Docker containers and images
+ pkgver = 0.6
+ pkgrel = 5
+ url = http://moncho.github.io/dry/
+ arch = x86_64
+ arch = i686
+ license = MPL2
+ depends = glibc
+ source = dry::https://github.com/moncho/dry/releases/download/v0.6-alpha.5/dry-linux-amd64
+ sha256sums = c787562a8b7276e755b9d9a8e9eb3717237866ea18fe7fe79aa076875fc6eb3e
+
+pkgname = dry-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e05a23cdd51a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+pkg/
+src/
+*.zip
+*.tar.gz
+*.pkg.tar.xz
+dry
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aab6e6f3c8c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Danilo Kuehn <dk[at]nogo-software[dot]de>
+
+_pkgname=dry
+_pkgver=v0.6-alpha.5
+pkgname=dry-bin
+pkgver=0.6
+pkgrel=5
+pkgdesc="dry is a terminal application to manage Docker containers and images"
+url="http://moncho.github.io/dry/"
+arch=('x86_64' 'i686')
+license=('MPL2')
+depends=('glibc')
+if test "$CARCH" == i686; then
+source=(
+ "${_pkgname}::https://github.com/moncho/dry/releases/download/${_pkgver}/dry-linux-386"
+)
+sha256sums=(
+ '814f9c65066d43e4c395e5f929c723ecc37b7bf3c855db2cf79f8733eb8e17ae'
+)
+else
+source=(
+ "${_pkgname}::https://github.com/moncho/dry/releases/download/${_pkgver}/dry-linux-amd64"
+)
+sha256sums=(
+ 'c787562a8b7276e755b9d9a8e9eb3717237866ea18fe7fe79aa076875fc6eb3e'
+)
+fi
+
+package() {
+ install -Dm755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}