summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLauri Niskanen2015-08-31 18:48:16 +0300
committerLauri Niskanen2015-08-31 18:48:16 +0300
commita3a3311141ee34429e01041de403de0c40cfa4dd (patch)
tree4469398e4680afefcd3906fd415a80613157606e
downloadaur-a3a3311141ee34429e01041de403de0c40cfa4dd.tar.gz
Migrate from old AUR
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
-rw-r--r--ds4drv.install3
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..47df98872888
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ds4drv
+ pkgdesc = Sony DualShock 4 Userspace Driver
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/chrippa/ds4drv
+ install = ds4drv.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-setuptools
+ depends = bluez-utils
+ depends = python-evdev
+ depends = python-pyudev
+ conflicts = ds4drv-git
+ source = https://github.com/chrippa/ds4drv/archive/v0.5.0.tar.gz
+ sha256sums = 43a7a977911a4fbfec9cd9f13e8085a73d89812201adf42c94dc97c118f6e24f
+
+pkgname = ds4drv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b7f5ce544a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Lauri Niskanen <ape@ape3000.com>
+# Contributor: George Gibbs <vash63 at gmail dot com>
+
+pkgname=ds4drv
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="Sony DualShock 4 Userspace Driver"
+arch=('any')
+url="https://github.com/chrippa/ds4drv"
+license=('MIT')
+depends=('python-setuptools' 'bluez-utils' 'python-evdev' 'python-pyudev')
+makedepends=('git')
+conflicts=('ds4drv-git')
+install=ds4drv.install
+source=(https://github.com/chrippa/ds4drv/archive/v$pkgver.tar.gz)
+sha256sums=('43a7a977911a4fbfec9cd9f13e8085a73d89812201adf42c94dc97c118f6e24f')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -pm755 $pkgdir/etc/udev/rules.d
+ cp udev/50-ds4drv.rules $pkgdir/etc/udev/rules.d/50-ds4drv.rules
+ mkdir -pm755 $pkgdir/usr/share/licenses/$pkgname
+ cp LICENSE $pkgdir/usr/share/licenses/$pkgname/
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -pm755 $pkgdir/etc/systemd/system
+ cp systemd/ds4drv.service $pkgdir/etc/systemd/system/ds4drv.service
+ cp ds4drv.conf $pkgdir/etc/ds4drv.conf
+}
+
+# vim: ft=sh syn=sh
diff --git a/ds4drv.install b/ds4drv.install
new file mode 100644
index 000000000000..a9658332d27e
--- /dev/null
+++ b/ds4drv.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo $'You must run the following command to allow ds4drv access to uinput:\nudevadm control --reload-rules; rmmod uinput; modprobe uinput\nAlso, on some systems it may be necessary for you to force the uinput module to load at boot, as follows:\necho \"uinput\" > /etc/modules-load.d/uinput.conf'
+}