summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Gardling2020-07-01 21:23:54 -0400
committerSimon Gardling2020-07-01 21:23:54 -0400
commite32a0edfb50bb1e2f13b92f12bbd46a7c483e6cb (patch)
tree0f8eef56dd006bab332592d321abe091ca44fe2a
downloadaur-e32a0edfb50bb1e2f13b92f12bbd46a7c483e6cb.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
-rw-r--r--ds4drv.install3
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..254f1cff30c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ds4drv-cemuhook-git
+ pkgdesc = Sony DualShock 4 Userspace Driver (with additions for cemu and DSU motion control)
+ pkgver = 0.5.1.216.8d3e126
+ pkgrel = 1
+ url = https://github.com/TheDrHax/ds4drv-cemuhook
+ install = ds4drv.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-setuptools
+ depends = bluez-utils-compat
+ depends = python-evdev
+ depends = python-pyudev
+ conflicts = ds4drv
+ conflicts = ds4drv-git
+ source = git+https://github.com/TheDrHax/ds4drv-cemuhook
+ sha256sums = SKIP
+
+pkgname = ds4drv-cemuhook-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2316153a0f80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Simon Gardling (titaniumtown) <titaniumtown@gmail.com>
+# Contributor: Lauri Niskanen <ape@ape3000.com>
+# Contributor: George Gibbs <vash63 at gmail dot com>
+
+pkgname=ds4drv-cemuhook-git
+pkgver=0.5.1.216.8d3e126
+pkgrel=1
+pkgdesc="Sony DualShock 4 Userspace Driver (with additions for cemu and DSU motion control)"
+arch=('any')
+url="https://github.com/TheDrHax/ds4drv-cemuhook"
+license=('MIT')
+depends=('python-setuptools' 'bluez-utils-compat' 'python-evdev' 'python-pyudev')
+makedepends=('git')
+conflicts=('ds4drv' 'ds4drv-git')
+install=ds4drv.install
+source=(git+https://github.com/TheDrHax/ds4drv-cemuhook)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ds4drv-cemuhook
+ version=$(grep version setup.py | sed 's/ version=\"//' | sed 's/\",//')
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $version.$revision.$hash
+}
+
+package() {
+ cd ds4drv-cemuhook
+ mkdir -pm755 $pkgdir/etc/udev/rules.d
+ cp udev/50-ds4drv.rules $pkgdir/etc/udev/rules.d/50-ds4drv.rules
+ mkdir -pm755 $pkgdir/usr/share/licenses/$pkgname
+ cp LICENSE $pkgdir/usr/share/licenses/$pkgname/
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -pm755 $pkgdir/etc/systemd/system
+ cp systemd/ds4drv.service $pkgdir/etc/systemd/system/ds4drv.service
+ cp ds4drv.conf $pkgdir/etc/ds4drv.conf
+}
+
+# vim: ft=sh syn=sh
diff --git a/ds4drv.install b/ds4drv.install
new file mode 100644
index 000000000000..a9658332d27e
--- /dev/null
+++ b/ds4drv.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo $'You must run the following command to allow ds4drv access to uinput:\nudevadm control --reload-rules; rmmod uinput; modprobe uinput\nAlso, on some systems it may be necessary for you to force the uinput module to load at boot, as follows:\necho \"uinput\" > /etc/modules-load.d/uinput.conf'
+}