summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-09-04 11:23:10 +0200
committerLubosz Sarnecki2015-09-04 11:23:10 +0200
commit6594e38b15a08a513c4927ed640a44b92c6192d8 (patch)
tree5ebfa5fcb6edbfd00d26fa8641f8cf8a4713a411
downloadaur-6594e38b15a08a513c4927ed640a44b92c6192d8.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--ds4drv.install3
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e867b2dd2ec8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ds4drv-git
+ pkgdesc = Sony DualShock 4 Userspace Driver
+ pkgver = 0.5.0.167.a7e1735
+ pkgrel = 1
+ url = https://github.com/chrippa/ds4drv
+ install = ds4drv.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-setuptools
+ depends = bluez-utils
+ depends = python-evdev
+ depends = python-pyudev
+ conflicts = ds4drv
+ source = git+https://github.com/chrippa/ds4drv.git
+ sha256sums = SKIP
+
+pkgname = ds4drv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fa4b300ff6c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Lauri Niskanen <ape@ape3000.com>
+# Contributor: George Gibbs <vash63 at gmail dot com>
+
+pkgname=ds4drv-git
+pkgver=0.5.0.167.a7e1735
+pkgrel=1
+pkgdesc="Sony DualShock 4 Userspace Driver"
+arch=('any')
+url="https://github.com/chrippa/ds4drv"
+license=('MIT')
+depends=('python-setuptools' 'bluez-utils' 'python-evdev' 'python-pyudev')
+makedepends=('git')
+conflicts=('ds4drv')
+install=ds4drv.install
+source=(git+https://github.com/chrippa/ds4drv.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ds4drv
+ version=$(grep version setup.py | sed 's/ version=\"//' | sed 's/\",//')
+ hash=$(git log --pretty=format:'%h' -n 1)
+ revision=$(git rev-list --count HEAD)
+ echo $version.$revision.$hash
+}
+
+package() {
+ cd ds4drv
+ mkdir -pm755 $pkgdir/etc/udev/rules.d
+ cp udev/50-ds4drv.rules $pkgdir/etc/udev/rules.d/50-ds4drv.rules
+ mkdir -pm755 $pkgdir/usr/share/licenses/$pkgname
+ cp LICENSE $pkgdir/usr/share/licenses/$pkgname/
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -pm755 $pkgdir/etc/systemd/system
+ cp systemd/ds4drv.service $pkgdir/etc/systemd/system/ds4drv.service
+ cp ds4drv.conf $pkgdir/etc/ds4drv.conf
+}
+
+# vim: ft=sh syn=sh
diff --git a/ds4drv.install b/ds4drv.install
new file mode 100644
index 000000000000..a9658332d27e
--- /dev/null
+++ b/ds4drv.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo $'You must run the following command to allow ds4drv access to uinput:\nudevadm control --reload-rules; rmmod uinput; modprobe uinput\nAlso, on some systems it may be necessary for you to force the uinput module to load at boot, as follows:\necho \"uinput\" > /etc/modules-load.d/uinput.conf'
+}