summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYigit Dallilar2021-03-02 20:42:16 +0100
committerYigit Dallilar2021-03-02 20:42:16 +0100
commite9b51e32576a360144dd7ceb1bd2de75a118b0c7 (patch)
treec31a47b274967b02dde43a536f1cc7ea783faa93
parentc15bbab094ee2878814fd71832ce2c052ed5fda6 (diff)
downloadaur-e9b51e32576a360144dd7ceb1bd2de75a118b0c7.tar.gz
v8.1.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
-rw-r--r--fix_bool.patch87
3 files changed, 9 insertions, 104 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3a91fc65538f..7acd41215566 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ds9
pkgdesc = SAOImage DS9: Astronomical Data Visualization Application
- pkgver = 8.2
- pkgrel = 2
+ pkgver = 8.2.1
+ pkgrel = 1
url = http://hea-www.harvard.edu/RD/ds9/
arch = x86_64
license = GPL2
@@ -13,14 +13,12 @@ pkgbase = ds9
makedepends = zip
provides = ds9
options = !strip
- source = https://github.com/SAOImageDS9/SAOImageDS9/archive/v8.2.tar.gz
+ source = https://github.com/SAOImageDS9/SAOImageDS9/archive/v8.2.1.tar.gz
source = ds9.desktop
source = ds9.png
- source = fix_bool.patch
- md5sums = 24805b1e78b8a78e55c62dd3f83c8a0d
+ md5sums = fdac9f96738a83f823a61e3ec887676f
md5sums = f1738e4ec665ae9afd1b65b86e6a07f1
md5sums = 9297d5738f5f462831075c483dc785d5
- md5sums = e7b894e7791036a1b1d049a11a55ae44
pkgname = ds9
diff --git a/PKGBUILD b/PKGBUILD
index 26e1c90ac9e9..95f3b3aaeb03 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Yigit Dallilar <yigit.dallilar at gmail dot com>
pkgname=ds9
-pkgver=8.2
-pkgrel=2
+pkgver=8.2.1
+pkgrel=1
pkgdesc="SAOImage DS9: Astronomical Data Visualization Application"
url="http://hea-www.harvard.edu/RD/ds9/"
arch=('x86_64')
@@ -17,17 +17,11 @@ replaces=()
backup=()
source=("https://github.com/SAOImageDS9/SAOImageDS9/archive/v${pkgver}.tar.gz"
"ds9.desktop"
- "ds9.png"
- "fix_bool.patch")
-md5sums=('24805b1e78b8a78e55c62dd3f83c8a0d'
+ "ds9.png")
+md5sums=('fdac9f96738a83f823a61e3ec887676f'
'f1738e4ec665ae9afd1b65b86e6a07f1'
- '9297d5738f5f462831075c483dc785d5'
- 'e7b894e7791036a1b1d049a11a55ae44')
+ '9297d5738f5f462831075c483dc785d5')
-prepare() {
- cd ${srcdir}/SAOImageDS9-${pkgver}
- patch --forward --strip=1 --input="${srcdir}/fix_bool.patch"
-}
build() {
cd ${srcdir}/SAOImageDS9-${pkgver}
diff --git a/fix_bool.patch b/fix_bool.patch
deleted file mode 100644
index 8b95d360356f..000000000000
--- a/fix_bool.patch
+++ /dev/null
@@ -1,87 +0,0 @@
-Only in SAOImageDS9-8.2.new: SAOImageDS9-8.2
-diff --unified --recursive --text SAOImageDS9-8.2/tclxml/tclxml.c SAOImageDS9-8.2.new/tclxml/tclxml.c
---- SAOImageDS9-8.2/tclxml/tclxml.c 2020-11-18 21:31:12.000000000 +0100
-+++ SAOImageDS9-8.2.new/tclxml/tclxml.c 2020-12-30 23:31:04.193966521 +0100
-@@ -1580,7 +1580,7 @@
- int objc;
- Tcl_Obj *CONST objv[];
- {
-- int index, bool, doParse = 0, result;
-+ int index, boolv, doParse = 0, result;
- TclXML_ParserClassInfo *classinfo = (TclXML_ParserClassInfo *) xmlinfo->parserClass;
-
- while (objc > 1) {
-@@ -1639,14 +1639,14 @@
- switch ((enum instanceConfigureSwitches) index) {
- case TCLXML_FINAL: /* -final */
-
-- if (Tcl_GetBooleanFromObj(interp, objv[1], &bool) != TCL_OK) {
-+ if (Tcl_GetBooleanFromObj(interp, objv[1], &boolv) != TCL_OK) {
- return TCL_ERROR;
- }
-
-- if (bool && !xmlinfo->final) {
-+ if (boolv && !xmlinfo->final) {
- doParse = 1;
-
-- } else if (!bool && xmlinfo->final) {
-+ } else if (!boolv && xmlinfo->final) {
- /*
- * Reset the parser for new input
- */
-@@ -1654,7 +1654,7 @@
- TclXMLResetParser(interp, xmlinfo);
- doParse = 0;
- }
-- xmlinfo->final = bool;
-+ xmlinfo->final = boolv;
- break;
-
- case TCLXML_ENCODING: /* -encoding */
-@@ -1666,14 +1666,14 @@
- break;
-
- case TCLXML_VALIDATE: /* -validate */
-- if (Tcl_GetBooleanFromObj(interp, objv[1], &bool) != TCL_OK) {
-+ if (Tcl_GetBooleanFromObj(interp, objv[1], &boolv) != TCL_OK) {
- return TCL_ERROR;
- }
- /*
- * If the parser is in the middle of parsing a document,
- * this will be ignored. Perhaps an error should be returned?
- */
-- xmlinfo->validate = bool;
-+ xmlinfo->validate = boolv;
- break;
-
- case TCLXML_BASEURL: /* -baseurl, -baseuri */
-@@ -1688,10 +1688,10 @@
-
- case TCLXML_DEFAULTEXPANDINTERNALENTITIES: /* -defaultexpandinternalentities */
- /* ericm@scriptics */
-- if (Tcl_GetBooleanFromObj(interp, objv[1], &bool) != TCL_OK) {
-+ if (Tcl_GetBooleanFromObj(interp, objv[1], &boolv) != TCL_OK) {
- return TCL_ERROR;
- }
-- xmlinfo->expandinternalentities = bool;
-+ xmlinfo->expandinternalentities = boolv;
- break;
-
- case TCLXML_PARAMENTITYPARSING:
-diff --unified --recursive --text SAOImageDS9-8.2/tclxml/tclxslt-libxslt.c SAOImageDS9-8.2.new/tclxml/tclxslt-libxslt.c
---- SAOImageDS9-8.2/tclxml/tclxslt-libxslt.c 2020-11-18 21:31:12.000000000 +0100
-+++ SAOImageDS9-8.2.new/tclxml/tclxslt-libxslt.c 2020-12-30 23:31:04.197299853 +0100
-@@ -1565,10 +1565,10 @@
- return NULL;
- }
- } else if (objPtr->typePtr == Tcl_GetObjType("boolean")) {
-- int bool;
-+ int boolv;
-
-- if (Tcl_GetBooleanFromObj(interp, objPtr, &bool) == TCL_OK) {
-- return xmlXPathNewBoolean(bool);
-+ if (Tcl_GetBooleanFromObj(interp, objPtr, &boolv) == TCL_OK) {
-+ return xmlXPathNewBoolean(boolv);
- } else {
- return NULL;
- }