summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Printzell2017-07-24 15:19:37 +0200
committerDan Printzell2017-07-24 15:19:37 +0200
commit408cbdf6449449a2cd68f8d1825cb58ebb68fae9 (patch)
tree250de5ffa2d4dcc009f10cdaf58d49d947e6a76d
parentcee14a46998be5097cbe8a96d27d6c198bf03da2 (diff)
downloadaur-408cbdf6449449a2cd68f8d1825cb58ebb68fae9.tar.gz
Fixed pkgver and submodules
Signed-off-by: Dan Printzell <xwildn00bx@gmail.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD23
2 files changed, 32 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1c2e8704c892..82f4e58df9a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Jul 24 01:29:45 UTC 2017
+# Mon Jul 24 13:18:27 UTC 2017
pkgbase = dscanner-git
pkgdesc = Swiss-army knife for D source code
- pkgver = r1098.0b064a0
+ pkgver = 0.4.0.r73.0b064a0
pkgrel = 1
url = https://github.com/dlang-community/D-Scanner
arch = i686
@@ -15,6 +15,16 @@ pkgbase = dscanner-git
provides = dscanner
conflicts = dscanner
source = git+https://github.com/dlang-community/D-Scanner
+ source = git+https://github.com/Hackerpilot/libdparse
+ source = git+https://github.com/burner/inifiled
+ source = git+https://github.com/economicmodeling/containers
+ source = git+https://github.com/Hackerpilot/dsymbol
+ source = git+https://github.com/economicmodeling/libddoc
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = dscanner-git
diff --git a/PKGBUILD b/PKGBUILD
index f541b548dbb9..227f227a3fb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Dan Printzell <arch@vild.io>
pkgname=('dscanner-git')
-pkgver=r1098.0b064a0
+pkgver=0.4.0.r73.0b064a0
pkgrel=1
pkgdesc="Swiss-army knife for D source code"
arch=('i686' 'x86_64')
@@ -15,19 +15,36 @@ conflicts=('dscanner')
source=(
"git+https://github.com/dlang-community/D-Scanner"
+ "git+https://github.com/Hackerpilot/libdparse"
+ "git+https://github.com/burner/inifiled"
+ "git+https://github.com/economicmodeling/containers"
+ "git+https://github.com/Hackerpilot/dsymbol"
+ "git+https://github.com/economicmodeling/libddoc"
)
sha256sums=(
'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
pkgver() {
cd "$srcdir/D-Scanner"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {
cd "$srcdir/D-Scanner"
- git submodule update --init --recursive
+
+ git submodule init
+ git config submodule.libdparse.url "$srcdir/libdparse"
+ git config submodule.inifiled.url "$srcdir/inifiled"
+ git config submodule.containers.url "$srcdir/containers"
+ git config submodule.dsymbol.url "$srcdir/dsymbol"
+ git config submodule.libddoc.url "$srcdir/libddoc"
+ git submodule update
}
build() {