summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormuhas2020-09-26 15:16:22 +0300
committermuhas2020-09-26 15:16:22 +0300
commit21b0440ed8a2b05d62dd7da3dd739d6e29e249f1 (patch)
tree45bb2380672534120297ed63bb6ac026e1855152
downloadaur-21b0440ed8a2b05d62dd7da3dd739d6e29e249f1.tar.gz
start pkg
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD41
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb102ce96f8a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = dscp
+ pkgdesc = frontend for scp and ssh (dsh like)
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/muhas/dscp
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = openssh
+
+pkgname = dscp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5577ac550c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Contributor: muhas <muhas@mail.ru>
+pkgname=dscp
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="frontend for scp and ssh (dsh like)"
+url="https://github.com/muhas/dscp"
+license=("GPL")
+depends=('openssh')
+makedepends=('git')
+arch=('any')
+source=()
+md5sums=()
+
+_gitdir="dscp"
+_giturl="https://github.com/muhas/dscp"
+_gitbranch="master"
+_commit="6c2c726e2cc36555b8107335e4d06a48e9cd25bc"
+
+build() {
+ # Change into source directory
+ cd "${srcdir}"
+
+ # Clone or pull from GIT server, and notify user of the status
+ msg "Connecting to GIT server...."
+ if [[ -d $_gitdir ]] ; then
+ cd "$_gitdir" && git pull origin "$_gitbranch"
+ msg "The local files are updated."
+ else
+ git clone "$_giturl" "$_gitdir"
+ cd "$_gitdir"
+ fi
+ git checkout "$_commit"
+}
+
+package() {
+ cd "$srcdir/$_gitdir"
+ cp $pkgname $pkgdir/$pkgname
+ chmod +x $pkgdir/$pkgname
+}
+
+