summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-24 18:44:14 +0300
committerDimitris Kiziridis2020-04-24 18:44:14 +0300
commit0021a7278eb6cfa762a806a0c3bec1193d62bfa1 (patch)
tree7c0e3b8b94a0354d685e93353ca6ecd0fa266856
downloadaur-0021a7278eb6cfa762a806a0c3bec1193d62bfa1.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3cfefa221f9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = dseams
+ pkgdesc = Deferred Structural Elucidation Analysis for Molecular Simulations
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://dseams.info
+ arch = x86_64
+ license = GPL-3.0
+ depends = gsl
+ depends = boost
+ depends = lua
+ depends = blas
+ depends = editline
+ depends = lapack
+ depends = rang
+ depends = yaml-cpp
+ depends = catch2
+ source = https://github.com/d-SEAMS/seams-core/archive/v1.0.0.tar.gz
+ sha256sums = 7cf6296372aee00ff94acc1219b9eb88697df25c73de23aec7957e013645c36b
+
+pkgname = dseams
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7832013abd9c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=dseams
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Deferred Structural Elucidation Analysis for Molecular Simulations"
+arch=('x86_64')
+url='https://dseams.info'
+license=('GPL-3.0')
+depends=('gsl'
+ 'boost'
+ 'lua'
+ 'blas'
+ 'editline'
+ 'lapack'
+ 'rang'
+ 'yaml-cpp'
+ 'catch2')
+source=("https://github.com/d-SEAMS/seams-core/archive/v${pkgver}.tar.gz")
+sha256sums=('7cf6296372aee00ff94acc1219b9eb88697df25c73de23aec7957e013645c36b')
+
+prepare() {
+ cd "${srcdir}/seams-core-${pkgver}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+}
+
+build() {
+ cd "${srcdir}/seams-core-${pkgver}/build"
+ make
+}
+
+package() {
+ cd "${srcdir}/seams-core-${pkgver}/build"
+ make DESTDIR=${pkgdir} install
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/dseams/LICENSE"
+} \ No newline at end of file