summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-11 05:55:37 +0300
committerDimitris Kiziridis2020-05-11 05:55:37 +0300
commita93e6c4615673ce6784aaf09e27e1374e3798cf3 (patch)
treed721a1cdfa40223823b578978f33f96882e33c4b
parent0021a7278eb6cfa762a806a0c3bec1193d62bfa1 (diff)
downloadaur-a93e6c4615673ce6784aaf09e27e1374e3798cf3.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD25
2 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3cfefa221f9a..05091f2613af 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,17 +4,18 @@ pkgbase = dseams
pkgrel = 1
url = https://dseams.info
arch = x86_64
- license = GPL-3.0
- depends = gsl
- depends = boost
- depends = lua
- depends = blas
- depends = editline
- depends = lapack
- depends = rang
+ license = GPL3
+ makedepends = boost
+ makedepends = blas
+ makedepends = editline
+ makedepends = lapack
+ makedepends = rang
+ makedepends = catch2
+ depends = fmt
depends = yaml-cpp
- depends = catch2
- source = https://github.com/d-SEAMS/seams-core/archive/v1.0.0.tar.gz
+ depends = lua
+ depends = gsl
+ source = dseams-1.0.0.tar.gz::https://github.com/d-SEAMS/seams-core/archive/v1.0.0.tar.gz
sha256sums = 7cf6296372aee00ff94acc1219b9eb88697df25c73de23aec7957e013645c36b
pkgname = dseams
diff --git a/PKGBUILD b/PKGBUILD
index 7832013abd9c..701f2ddfc4ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,21 +6,25 @@ pkgrel=1
pkgdesc="Deferred Structural Elucidation Analysis for Molecular Simulations"
arch=('x86_64')
url='https://dseams.info'
-license=('GPL-3.0')
-depends=('gsl'
- 'boost'
- 'lua'
- 'blas'
- 'editline'
- 'lapack'
- 'rang'
+license=('GPL3')
+depends=('fmt'
'yaml-cpp'
- 'catch2')
-source=("https://github.com/d-SEAMS/seams-core/archive/v${pkgver}.tar.gz")
+ 'lua'
+ 'gsl')
+makedepends=('boost'
+ 'blas'
+ 'editline'
+ 'lapack'
+ 'rang'
+ 'catch2')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/d-SEAMS/seams-core/archive/v${pkgver}.tar.gz")
sha256sums=('7cf6296372aee00ff94acc1219b9eb88697df25c73de23aec7957e013645c36b')
prepare() {
cd "${srcdir}/seams-core-${pkgver}"
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
@@ -34,5 +38,4 @@ build() {
package() {
cd "${srcdir}/seams-core-${pkgver}/build"
make DESTDIR=${pkgdir} install
- install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/dseams/LICENSE"
} \ No newline at end of file