summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-11 05:57:45 +0300
committerDimitris Kiziridis2020-05-11 05:57:45 +0300
commit9c2912ef068c655d19841ba4fd384dd54ebf952d (patch)
treeacdd7739cb81f6457bed4f839507030fea0f20f6
parentdf012af4d5e6333716e34e8f3b5836b50310d3b0 (diff)
downloadaur-9c2912ef068c655d19841ba4fd384dd54ebf952d.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d14db17b54fd..6bbeebea0429 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,17 +4,17 @@ pkgbase = dseams-git
pkgrel = 1
url = https://dseams.info
arch = x86_64
- license = GPL-3.0
- makedepends = git
- depends = gsl
- depends = boost
- depends = lua
- depends = blas
- depends = editline
- depends = lapack
- depends = rang
+ license = GPL3
+ makedepends = boost
+ makedepends = blas
+ makedepends = editline
+ makedepends = lapack
+ makedepends = rang
+ makedepends = catch2
+ depends = fmt
depends = yaml-cpp
- depends = catch2
+ depends = lua
+ depends = gsl
provides = dseams
source = git+https://github.com/d-SEAMS/seams-core
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 887c5c2cda0d..cb06de7efc5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,18 +6,18 @@ pkgrel=1
pkgdesc="Deferred Structural Elucidation Analysis for Molecular Simulations"
arch=('x86_64')
url='https://dseams.info'
-license=('GPL-3.0')
+license=('GPL3')
provides=("${pkgname%-git}")
-depends=('gsl'
- 'boost'
- 'lua'
- 'blas'
- 'editline'
- 'lapack'
- 'rang'
+depends=('fmt'
'yaml-cpp'
- 'catch2')
-makedepends=('git')
+ 'lua'
+ 'gsl')
+makedepends=('boost'
+ 'blas'
+ 'editline'
+ 'lapack'
+ 'rang'
+ 'catch2')
source=("git+https://github.com/d-SEAMS/seams-core")
md5sums=('SKIP')
@@ -28,6 +28,9 @@ pkgver() {
prepare() {
cd "${srcdir}/seams-core"
+ if [[ -d build ]]; then
+ rm -rf build
+ fi
mkdir build
cd build
cmake -DCMAKE_INSTALL_PREFIX=/usr ..
@@ -41,5 +44,4 @@ build() {
package() {
cd "${srcdir}/seams-core/build"
make DESTDIR=${pkgdir} install
- install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/dseams/LICENSE"
} \ No newline at end of file