summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-04-24 18:44:29 +0300
committerDimitris Kiziridis2020-04-24 18:44:29 +0300
commitdf012af4d5e6333716e34e8f3b5836b50310d3b0 (patch)
tree9f069dcc2102b73e93ed7535c696c66805da2b13
downloadaur-df012af4d5e6333716e34e8f3b5836b50310d3b0.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d14db17b54fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = dseams-git
+ pkgdesc = Deferred Structural Elucidation Analysis for Molecular Simulations
+ pkgver = 1.0.0.r14.g333cc82
+ pkgrel = 1
+ url = https://dseams.info
+ arch = x86_64
+ license = GPL-3.0
+ makedepends = git
+ depends = gsl
+ depends = boost
+ depends = lua
+ depends = blas
+ depends = editline
+ depends = lapack
+ depends = rang
+ depends = yaml-cpp
+ depends = catch2
+ provides = dseams
+ source = git+https://github.com/d-SEAMS/seams-core
+ md5sums = SKIP
+
+pkgname = dseams-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..887c5c2cda0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=dseams-git
+pkgver=1.0.0.r14.g333cc82
+pkgrel=1
+pkgdesc="Deferred Structural Elucidation Analysis for Molecular Simulations"
+arch=('x86_64')
+url='https://dseams.info'
+license=('GPL-3.0')
+provides=("${pkgname%-git}")
+depends=('gsl'
+ 'boost'
+ 'lua'
+ 'blas'
+ 'editline'
+ 'lapack'
+ 'rang'
+ 'yaml-cpp'
+ 'catch2')
+makedepends=('git')
+source=("git+https://github.com/d-SEAMS/seams-core")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/seams-core"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/seams-core"
+ mkdir build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+}
+
+build() {
+ cd "${srcdir}/seams-core/build"
+ make
+}
+
+package() {
+ cd "${srcdir}/seams-core/build"
+ make DESTDIR=${pkgdir} install
+ install -Dm644 ../LICENSE "${pkgdir}/usr/share/licenses/dseams/LICENSE"
+} \ No newline at end of file