summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspider-mario2015-07-11 12:09:26 +0200
committerspider-mario2015-07-11 12:09:26 +0200
commitb6a085cdbcbbc6583090044e782d1cebd27b1a76 (patch)
tree7b9e1d78adb21ecfc40a2daf34764be7405d8958
downloadaur-b6a085cdbcbbc6583090044e782d1cebd27b1a76.tar.gz
initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cf9b906d539
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dsf2flac-svn
+ pkgdesc = A file conversion tool for translating dsf and dff dsd audio files into flac pcm audio files.
+ pkgver = 53
+ pkgrel = 1
+ url = https://code.google.com/p/dsf2flac
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = boost
+ makedepends = cmake
+ makedepends = subversion
+ depends = boost-libs
+ depends = flac
+ depends = id3lib
+ source = dsf2flac::svn+http://dsf2flac.googlecode.com/svn/trunk/
+ sha512sums = SKIP
+
+pkgname = dsf2flac-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13ee2e19b603
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: laloch <lalochcz@gmail.com>
+pkgname=dsf2flac-svn
+pkgver=53
+pkgrel=1
+pkgdesc="A file conversion tool for translating dsf and dff dsd audio files into flac pcm audio files."
+arch=('i686' 'x86_64')
+url="https://code.google.com/p/dsf2flac"
+license=('GPL3')
+depends=('boost-libs' 'flac' 'id3lib')
+makedepends=('boost' 'cmake' 'subversion')
+source=('dsf2flac::svn+http://dsf2flac.googlecode.com/svn/trunk/')
+sha512sums=('SKIP')
+
+pkgver() {
+ svnversion dsf2flac
+}
+
+prepare() {
+ cd dsf2flac
+ perl -ne 'print unless /-static/' -i CMakeLists.txt
+}
+
+build() {
+ rm -fr build
+ mkdir build
+ cd build
+
+ cmake -DCMAKE_BUILD_TYPE=Release "$srcdir"/dsf2flac
+ make
+}
+
+package() {
+ install -Dm755 build/dsf2flac "$pkgdir/usr/bin/dsf2flac"
+}
+
+# vim:set ts=2 sw=2 et: