summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit7154e41be4329e8fef2092e5747f89eb61a63c17 (patch)
tree195c5cd35b58a51e93bdcb1e08e2f0073289d966
downloadaur-7154e41be4329e8fef2092e5747f89eb61a63c17.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.AURINFO13
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD41
3 files changed, 67 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..c3f0f9debff1
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,13 @@
+pkgbase = dslib-git
+ pkgdesc = Free Python library for accessing Datove schranky
+ pkgver = 20140930
+ pkgrel = 1
+ url = https://labs.nic.cz/page/969/datovka/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ makedepends = git
+ depends = python2-pyopenssl
+
+pkgname = dslib-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c3f0f9debff1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = dslib-git
+ pkgdesc = Free Python library for accessing Datove schranky
+ pkgver = 20140930
+ pkgrel = 1
+ url = https://labs.nic.cz/page/969/datovka/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ makedepends = git
+ depends = python2-pyopenssl
+
+pkgname = dslib-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cac39d513620
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=dslib-git
+pkgver=20140930
+pkgrel=1
+pkgdesc="Free Python library for accessing Datove schranky"
+arch=('any')
+url="https://labs.nic.cz/page/969/datovka/"
+license=('LGPL')
+depends=('python2-pyopenssl')
+makedepends=('python2-setuptools' 'git')
+
+_gitroot="git://git.nic.cz/dslib/"
+_gitname="dslib"
+
+package() {
+ cd "${srcdir}"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "${srcdir}"/$_gitname-build
+ git clone "${srcdir}"/$_gitname "${srcdir}"/$_gitname-build
+ cd "${srcdir}"/$_gitname-build
+
+#Python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py install --root="${pkgdir}"
+}