summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Scott2014-06-20 14:58:17 -0700
committerIan Scott2014-06-20 14:58:17 -0700
commit67ed7ea6a93e668342b73b14686fe2bbede0e6ba (patch)
tree20b15fc269508ebda208f623b66c061e11ba1946
downloadaur-67ed7ea6a93e668342b73b14686fe2bbede0e6ba.tar.gz
Add dsmidiwifi-cli
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ea5f1224611
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = dsmidiwifi-cli
+ pkgdesc = DSMI Server with GUI Removed
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://github.com/ids1024/dsmidiwifi-cli
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ depends = qt5-base
+ depends = alsa-lib
+ source = https://github.com/ids1024/dsmidiwifi-cli/archive/v1.0.tar.gz
+ md5sums = 2c652ebd4d05689621da1a934ee20cc8
+
+pkgname = dsmidiwifi-cli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..38488267418b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ian D. Scott <ian@perebruin.com>
+pkgname=dsmidiwifi-cli
+pkgver=1.0
+pkgrel=1
+pkgdesc="DSMI Server with GUI Removed"
+url="http://github.com/ids1024/dsmidiwifi-cli"
+arch=('x86_64' 'i686')
+license=('GPL2')
+depends=('qt5-base' 'alsa-lib')
+source=("https://github.com/ids1024/${pkgname}/archive/v${pkgver}.tar.gz")
+md5sums=('2c652ebd4d05689621da1a934ee20cc8')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm755 dsmidiwifi-cli $pkgdir/usr/bin/dsmidiwifi-cli
+}
+
+# vim:set ts=2 sw=2 et: