summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLFdev2023-11-13 15:10:25 -0300
committerLFdev2023-11-13 15:10:25 -0300
commit8e3882a4139063067a333b757f3f0ddabd910aa7 (patch)
tree406b837e8b76d6d960cd2fd2f9157fb3f3ec4b2a
downloadaur-8e3882a4139063067a333b757f3f0ddabd910aa7.tar.gz
First commit
-rw-r--r--.SRCINFO50
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD90
-rw-r--r--dsnote.install12
4 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab5bfd956d9a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = dsnote
+ pkgdesc = Note taking, reading and translating with offline Speech to Text, Text to Speech and Machine Translation
+ pkgver = 4.3.0
+ pkgrel = 1
+ url = https://github.com/mkiol/dsnote
+ install = dsnote.install
+ arch = x86_64
+ license = MPL2
+ makedepends = boost
+ makedepends = cmake
+ makedepends = cuda
+ makedepends = extra-cmake-modules
+ makedepends = git
+ makedepends = meson
+ makedepends = pybind11
+ makedepends = qt5-tools
+ makedepends = rocm-hip-sdk
+ depends = boost-libs
+ depends = fmt
+ depends = hicolor-icon-theme
+ depends = kdbusaddons5
+ depends = kquickcharts5
+ depends = libarchive
+ depends = openblas
+ depends = perl
+ depends = python>=3.11
+ depends = qt5-base
+ depends = qt5-declarative
+ depends = qt5-x11extras
+ depends = qt5-multimedia
+ depends = qt5-quickcontrols2
+ depends = qqc2-desktop-style5
+ depends = rubberband
+ depends = taglib
+ depends = xz
+ optdepends = cuda: Support for GPU acceleration on NVidia graphic cards
+ optdepends = cudnn: Support for GPU acceleration on NVidia graphic cards
+ optdepends = ocl-icd: Support for GPU acceleration with OpenCL
+ optdepends = python-accelerate: Support for Punctuation and Hebrew Diacritics restoration
+ optdepends = python-torchaudio: Support for Coqui TTS models
+ optdepends = python-transformers: Support for Punctuation and Hebrew Diacritics restoration
+ optdepends = rocblas: Support for GPU acceleration on AMD graphic cards
+ optdepends = rocm-opencl-runtime: Support GPU acceleration on AMD graphic cards
+ optdepends = tts: Support for Coqui TTS models
+ provides = dsnote
+ conflicts = dsnote-git
+ source = https://github.com/mkiol/dsnote/archive/refs/tags/v4.3.0.tar.gz
+ sha256sums = f97d8d2365845cfa48610958a149db54b6b7d2f0154602e514807c29cf00e59d
+
+pkgname = dsnote
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..68a333844d3f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!dsnote.install \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3201675eecb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: LFdev <lfdev+aur at envs dot net>
+
+_pkgname='dsnote'
+pkgname="${_pkgname}"
+pkgver=4.3.0
+pkgrel=1
+pkgdesc="Note taking, reading and translating with offline Speech to Text, Text to Speech and Machine Translation"
+arch=('x86_64')
+url="https://github.com/mkiol/dsnote"
+license=('MPL2')
+depends=(
+ 'boost-libs'
+ 'fmt'
+ 'hicolor-icon-theme'
+ 'kdbusaddons5'
+ 'kquickcharts5'
+ 'libarchive'
+ 'openblas'
+ 'perl'
+ 'python>=3.11'
+ 'qt5-base'
+ 'qt5-declarative'
+ 'qt5-x11extras'
+ 'qt5-multimedia'
+ 'qt5-quickcontrols2'
+ 'qqc2-desktop-style5'
+ 'rubberband'
+ 'taglib'
+ 'xz'
+)
+makedepends=(
+ 'boost'
+ 'cmake'
+ 'cuda'
+ 'extra-cmake-modules'
+ 'git'
+ 'meson'
+ 'pybind11'
+ 'qt5-tools'
+ 'rocm-hip-sdk'
+)
+optdepends=(
+ 'cuda: Support for GPU acceleration on NVidia graphic cards'
+ 'cudnn: Support for GPU acceleration on NVidia graphic cards'
+ 'ocl-icd: Support for GPU acceleration with OpenCL'
+ 'python-accelerate: Support for Punctuation and Hebrew Diacritics restoration'
+ 'python-torchaudio: Support for Coqui TTS models'
+ 'python-transformers: Support for Punctuation and Hebrew Diacritics restoration'
+ 'rocblas: Support for GPU acceleration on AMD graphic cards'
+ 'rocm-opencl-runtime: Support GPU acceleration on AMD graphic cards'
+ 'tts: Support for Coqui TTS models'
+)
+provides=(${_pkgname})
+conflicts=(${_pkgname}-git)
+install=${_pkgname}.install
+source=(https://github.com/mkiol/dsnote/archive/refs/tags/v${pkgver}.tar.gz)
+sha256sums=('f97d8d2365845cfa48610958a149db54b6b7d2f0154602e514807c29cf00e59d')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ # fix for CUDA >= 12.3.0
+ export HOST_COMPILER=/usr/bin/g++-12
+ export CUDAHOSTCXX=/usr/bin/g++-12
+ export CUDA_PATH=/opt/cuda
+ mkdir -p build
+ cd build
+ cmake ../ -DCMAKE_BUILD_TYPE=Release -DWITH_DESKTOP=ON \
+ -DWITH_PY=ON \
+ -DBUILD_LIBARCHIVE=OFF \
+ -DBUILD_FMT=OFF \
+ -DBUILD_CATCH2=OFF \
+ -DBUILD_OPENBLAS=OFF \
+ -DBUILD_XZ=OFF \
+ -DBUILD_PYBIND11=OFF \
+ -DBUILD_RUBBERBAND=OFF \
+ -DBUILD_FFMPEG=ON \
+ -DBUILD_TAGLIB=OFF \
+ -DBUILD_VOSK=OFF \
+ -DBUILD_QQC2_BREEZE_STYLE=ON \
+ -DDOWNLOAD_VOSK=ON \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
+ test $(nproc) -gt 2 && make -j$(($(nproc)-2)) || make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd build
+ make DESTDIR="$pkgdir" install
+}
diff --git a/dsnote.install b/dsnote.install
new file mode 100644
index 000000000000..fd7e920cd297
--- /dev/null
+++ b/dsnote.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo "** Some features of Speech Note may require optional AUR or Python packages"
+ echo "** Please check the installation log, help or project page for more info"
+}
+
+post_upgrade() {
+ post_install
+}
+
+#post_remove() {
+ # placeholder
+#}