summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Barbour2017-01-11 16:26:44 -0500
committerMichael Barbour2017-01-11 16:26:44 -0500
commit8c8a779ab11e9a34ce612ab0fcda1ea4bab1d65f (patch)
treeeb607161c291f2c0b364175531d499da504c22e8
parentd911e11d282c8d870d2ea72aecaed6ce55969507 (diff)
downloadaur-8c8a779ab11e9a34ce612ab0fcda1ea4bab1d65f.tar.gz
Fix dependencies and build() function.
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cd2b8208a55..b6eca4638248 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Nov 22 09:56:52 UTC 2016
pkgbase = dsp-git
pkgdesc = An audio processing program with an interactive mode
- pkgver = 234.25a4b3e
+ pkgver = 241.6d1aa67
pkgrel = 1
url = https://github.com/bmc0/dsp
arch = i686
@@ -11,25 +9,16 @@ pkgbase = dsp-git
arch = armv7h
license = ISC
makedepends = git
- makedepends = fftw
- makedepends = libsndfile
- makedepends = ffmpeg
- makedepends = alsa-lib
- makedepends = libao
- makedepends = libmad
- makedepends = libpulse
- makedepends = ladspa
- makedepends = zita-convolver
- optdepends = fftw: For resample and fir effects
- optdepends = libsndfile: For sndfile input/output support
- optdepends = ffmpeg: For ffmpeg input support
- optdepends = alsa-lib: For alsa input/output support
- optdepends = libao: For ao output support
- optdepends = libmad: For mp3 input support
- optdepends = libpulse: For PulseAudio input/ouput support
- optdepends = ladspa: For building the LADSPA frontend
- optdepends = zita-convolver: For zita_convolver effect
- source = dsp::git+https://github.com/bmc0/dsp.git
+ depends = fftw
+ depends = libsndfile
+ depends = ffmpeg
+ depends = alsa-lib
+ depends = libao
+ depends = libmad
+ depends = libpulse
+ depends = ladspa
+ depends = zita-convolver
+ source = git+https://github.com/bmc0/dsp.git
md5sums = SKIP
pkgname = dsp-git
diff --git a/PKGBUILD b/PKGBUILD
index 227d00204a6e..b39dcfed98f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,18 @@
# Maintainer: Lauri Niskanen <ape@ape3000.com>
+# Maintainer: Michael Barbour <barbour.michael.0@gmail.com>
# Contributor: sekret
pkgname=dsp-git
_pkgname=dsp
-pkgver=234.25a4b3e
+pkgver=241.6d1aa67
pkgrel=1
pkgdesc="An audio processing program with an interactive mode"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/bmc0/${_pkgname}"
license=('ISC')
-makedepends=('git' 'fftw' 'libsndfile' 'ffmpeg' 'alsa-lib' 'libao' 'libmad' 'libpulse' 'ladspa' 'zita-convolver')
-optdepends=('fftw: For resample and fir effects'
- 'libsndfile: For sndfile input/output support'
- 'ffmpeg: For ffmpeg input support'
- 'alsa-lib: For alsa input/output support'
- 'libao: For ao output support'
- 'libmad: For mp3 input support'
- 'libpulse: For PulseAudio input/ouput support'
- 'ladspa: For building the LADSPA frontend'
- 'zita-convolver: For zita_convolver effect')
-source=(${_pkgname}::"git+https://github.com/bmc0/${_pkgname}.git")
+makedepends=('git')
+depends=('fftw' 'libsndfile' 'ffmpeg' 'alsa-lib' 'libao' 'libmad' 'libpulse' 'ladspa' 'zita-convolver')
+source=("git+https://github.com/bmc0/${_pkgname}.git")
md5sums=('SKIP')
pkgver() {
@@ -30,10 +23,13 @@ pkgver() {
build() {
cd "${srcdir}/${_pkgname}"
./configure --prefix=/usr
+ make
}
package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 LICENSE.GPL2 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.GPL2"
+ install -Dm644 LICENSE.LGPL2_1 "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.LGPL2_1"
}