summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2019-02-22 20:50:53 +0100
committerDavid Runge2019-02-22 20:50:53 +0100
commitcf9c33ed85923a45ee471f69277def1efd2c3608 (patch)
treede595a7bd7bc1fb0621d77532a2147897ab37667
downloadaur-dssi-vst.tar.gz
Moving from [community]. Setting up for full RELRO.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD45
-rw-r--r--dssi-vst-winexec.patch23
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d838b4343e00
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = dssi-vst
+ pkgdesc = DSSI adapter/wrapper for win32 VST plug-ins
+ pkgver = 0.9.2
+ pkgrel = 9
+ url = https://www.breakfastquay.com/dssi-vst/
+ arch = x86_64
+ groups = pro-audio
+ license = GPL2
+ makedepends = dssi
+ makedepends = ladspa
+ depends = wine
+ depends = jack
+ depends = liblo
+ source = https://code.breakfastquay.com/attachments/download/10/dssi-vst-0.9.2.tar.bz2
+ source = dssi-vst-winexec.patch
+ sha512sums = 647faa1f39dd6ffb13a23f23d5b150afa3fa20a4cb7c28fed8e71ff9b835e84f5410b24bf3b8c65fbdc147667e086cc165469f68da0132fa7a9c06b6ca17561f
+ sha512sums = 2f4474554fec716a63ff7a54c06872aad79eda100df74b108afbcc7307116d6b9159c270d84f14112e5c52bbe543c18bcd455fc6022cf6266ffea086baf602d8
+
+pkgname = dssi-vst
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0d311075eee1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: David Runge <dave@sleepmap.de>
+# Contributor: speps <speps at aur dot archlinux dot org>
+# Contributor: Ray Rashif <schivmeister@gmail.com>
+
+pkgname=dssi-vst
+pkgver=0.9.2
+pkgrel=9
+pkgdesc="DSSI adapter/wrapper for win32 VST plug-ins"
+arch=('x86_64')
+url="https://www.breakfastquay.com/dssi-vst/"
+license=('GPL2')
+groups=('pro-audio')
+depends=('wine' 'jack' 'liblo')
+makedepends=('dssi' 'ladspa')
+source=("https://code.breakfastquay.com/attachments/download/10/${pkgname}-${pkgver}.tar.bz2"
+ "${pkgname}-winexec.patch")
+sha512sums=('647faa1f39dd6ffb13a23f23d5b150afa3fa20a4cb7c28fed8e71ff9b835e84f5410b24bf3b8c65fbdc147667e086cc165469f68da0132fa7a9c06b6ca17561f'
+ '2f4474554fec716a63ff7a54c06872aad79eda100df74b108afbcc7307116d6b9159c270d84f14112e5c52bbe543c18bcd455fc6022cf6266ffea086baf602d8')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ # fix executable extension issue
+ patch -Np1 -i "${srcdir}/${pkgname}-winexec.patch"
+
+ # use CXXFLAGS in build
+ sed -i "/m32/! s/CXXFLAGS)/& $CXXFLAGS/" Makefile
+
+ # /usr/lib32/dssi
+ sed -i '/\/dssi-vst/s|DSSIDIR|&32|' Makefile
+ sed -i '/DSSI_PATH/s|\(/usr/lib\)\(/dssi\)|&:\132\2|' remotevstclient.cpp
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ make LDFLAGS="${LDFLAGS}"
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ make BINDIR="${pkgdir}/usr/bin" \
+ DSSIDIR="${pkgdir}/usr/lib/dssi" \
+ DSSIDIR32="${pkgdir}/usr/lib32/dssi" \
+ LADSPADIR="${pkgdir}/usr/lib/ladspa" install
+}
diff --git a/dssi-vst-winexec.patch b/dssi-vst-winexec.patch
new file mode 100644
index 000000000000..2681e0ba9ae6
--- /dev/null
+++ b/dssi-vst-winexec.patch
@@ -0,0 +1,23 @@
+Thanks to Fernando Lopez-Lezcano <nando@ccrma.stanford.edu>
+Reviewed by speps <speps at aur dot archlinux dot org>
+
+diff -aur dssi-vst-0.9.2/Makefile dssi-vst-0.9.2.patched/Makefile
+--- dssi-vst-0.9.2/Makefile 2010-05-04 11:01:29.000000000 +0200
++++ dssi-vst-0.9.2.patched/Makefile 2014-03-28 18:24:41.128287015 +0100
+@@ -38,12 +38,15 @@
+ all: $(TARGETS)
+
+ install: all
++ mkdir -p $(DSSIDIR)
+ mkdir -p $(DSSIDIR)/dssi-vst
+ mkdir -p $(LADSPADIR)
+ mkdir -p $(BINDIR)
+ install dssi-vst.so $(DSSIDIR)
+ install dssi-vst.so $(LADSPADIR)
+- install dssi-vst-server.exe.so dssi-vst-server dssi-vst-scanner.exe.so dssi-vst-scanner dssi-vst_gui $(DSSIDIR)/dssi-vst
++ install dssi-vst-server.exe.so dssi-vst-scanner.exe.so dssi-vst_gui $(DSSIDIR)/dssi-vst
++ install dssi-vst-server.exe $(DSSIDIR)/dssi-vst/dssi-vst-server
++ install dssi-vst-scanner.exe $(DSSIDIR)/dssi-vst/dssi-vst-scanner
+ install vsthost $(BINDIR)
+
+ clean: