summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoreshizhan2017-09-09 22:37:04 +0800
committereshizhan2017-09-09 22:37:04 +0800
commita30cc312333ed0655be59e2faa634738a53fe566 (patch)
treea4e99710c2c7d5241d4eca280959be5047a53713
downloadaur-a30cc312333ed0655be59e2faa634738a53fe566.tar.gz
dstat Python 3 porting version
Signed-off-by: eshizhan <eshizhan@126.com>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b867dffc54b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = dstat-py3
+ pkgdesc = A versatile resource statistics tool, Python 3 porting
+ pkgver = 0.7.3py3
+ pkgrel = 1
+ url = https://github.com/eshizhan/dstat/
+ arch = any
+ license = GPL
+ depends = python
+ provides = dstat
+ source = https://github.com/eshizhan/dstat/archive/0.7.3py3.tar.gz
+ md5sums = cec63b7b9247c0c9586258851d9a1f11
+
+pkgname = dstat-py3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..619d953d8351
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id$
+# Maintainer: eshizhan <eshizhan@126.com>
+# Maintainer: Sven-Hendrik Haase <sh@lutzhaase.com>
+# Contributor: Schnouki <thomas.jost@gmail.com>
+# Contributor: devon <admin@patched.biz>
+
+pkgname=dstat-py3
+pkgver=0.7.3py3
+pkgrel=1
+pkgdesc="A versatile resource statistics tool, Python 3 porting"
+arch=('any')
+url="https://github.com/eshizhan/dstat/"
+license=('GPL')
+depends=('python')
+provides=('dstat')
+source=(https://github.com/eshizhan/dstat/archive/${pkgver}.tar.gz)
+md5sums=('cec63b7b9247c0c9586258851d9a1f11')
+
+package() {
+ cd $pkgname-$pkgver
+
+ make DESTDIR=$pkgdir install
+ make DESTDIR=$pkgdir docs
+}