summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Krug2016-02-02 23:18:00 +0100
committerThomas Krug2016-02-02 23:18:22 +0100
commit0c7a2c68d86a96878c3eefd4bb25b0cfd29d8d32 (patch)
tree547c0bfe70b7cf86d2eadec3c4aab8ce49bd0188
downloadaur-0c7a2c68d86a96878c3eefd4bb25b0cfd29d8d32.tar.gz
initial 0.95
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD49
-rw-r--r--dsview.desktop5
-rw-r--r--dsview.install13
-rw-r--r--path.patch60
-rw-r--r--udev.rules6
7 files changed, 170 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0bfdf10714fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 22:18:13 UTC 2016
+pkgbase = dsview
+ pkgdesc = Client software that supports the DreamSourceLab logic analyzer
+ pkgver = 0.95
+ pkgrel = 1
+ url = http://www.dreamsourcelab.com/
+ install = dsview.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = boost
+ depends = boost-libs
+ depends = qt5-base
+ depends = libsigrok4dsl
+ depends = libsigrokdecode
+ conflicts = dslogic
+ replaces = dslogic
+ source = git+https://github.com/DreamSourceLab/DSView.git#tag=0.95
+ source = path.patch
+ source = udev.rules
+ source = dsview.desktop
+ md5sums = SKIP
+ md5sums = f2b000eb19883bc16bca716b5da78da3
+ md5sums = af6d97ba0fbea628e320bdb4b469b766
+ md5sums = 095886809795b40d663bfe4b79395811
+
+pkgname = dsview
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5cc067f08aeb
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+pkg/
+src/
+*.swp
+*.pkg.tar.xz
+*.tar.gz
+
+DSView/
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbc80c672d72
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Thomas Krug <t.krug@elektronenpumpe.de>
+# Contributor: Thomas Krug <t.krug@elektronenpumpe.de>
+
+pkgname=dsview
+pkgver=0.95
+pkgrel=1
+pkgdesc="Client software that supports the DreamSourceLab logic analyzer"
+arch=('i686' 'x86_64')
+url="http://www.dreamsourcelab.com/"
+license=('GPL3')
+depends=('boost-libs' 'qt5-base' 'libsigrok4dsl' 'libsigrokdecode')
+makedepends=('boost')
+conflicts=('dslogic')
+replaces=('dslogic')
+source=("git+https://github.com/DreamSourceLab/DSView.git#tag=0.95"
+ 'path.patch'
+ 'udev.rules'
+ 'dsview.desktop')
+md5sums=('SKIP'
+ 'f2b000eb19883bc16bca716b5da78da3'
+ 'af6d97ba0fbea628e320bdb4b469b766'
+ '095886809795b40d663bfe4b79395811')
+install=dsview.install
+
+prepare() {
+ cd "$srcdir/DSView/DSView"
+
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_SKIP_RPATH=1 .
+
+ patch -Np1 -i "$srcdir/path.patch"
+}
+
+build() {
+ cd "$srcdir/DSView/DSView"
+
+ cmake .
+ make
+}
+
+package() {
+ cd "$srcdir/DSView/DSView"
+
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+
+ install -Dm644 "$srcdir/dsview.desktop" "$pkgdir/usr/share/applications/dsview.desktop"
+ install -Dm644 "$srcdir/udev.rules" "$pkgdir/usr/lib/udev/rules.d/20-dsview.rules"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/dsview.desktop b/dsview.desktop
new file mode 100644
index 000000000000..18388d1a5b99
--- /dev/null
+++ b/dsview.desktop
@@ -0,0 +1,5 @@
+[Desktop Entry]
+Exec=DSView
+Name=DSView
+Type=Application
+Categories=Development
diff --git a/dsview.install b/dsview.install
new file mode 100644
index 000000000000..a6a73e84bb47
--- /dev/null
+++ b/dsview.install
@@ -0,0 +1,13 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade(){
+ update-desktop-database -q
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/path.patch b/path.patch
new file mode 100644
index 000000000000..4d9b679c6ab7
--- /dev/null
+++ b/path.patch
@@ -0,0 +1,60 @@
+diff -Naur a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt 2016-02-02 12:46:46.432763024 +0100
++++ b/CMakeLists.txt 2016-02-02 12:51:42.589433577 +0100
+@@ -352,21 +352,21 @@
+
+ # Install the executable.
+ install(TARGETS ${PROJECT_NAME} DESTINATION bin/)
+-install(FILES res/DSLogic.fw DESTINATION bin/res/)
+-install(FILES res/DSLogic33.bin DESTINATION bin/res/)
+-install(FILES res/DSLogic50.bin DESTINATION bin/res/)
+-install(FILES res/DSLogicPro.fw DESTINATION bin/res/)
+-install(FILES res/DSLogicPro.bin DESTINATION bin/res/)
+-install(FILES res/DSCope.fw DESTINATION bin/res/)
+-install(FILES res/DSCope.bin DESTINATION bin/res/)
+-install(FILES res/DSLogic0.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic0.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic1.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic1.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic2.dsc DESTINATION bin/res/)
+-install(FILES res/DSLogic2.def.dsc DESTINATION bin/res/)
+-install(FILES res/DSCope1.dsc DESTINATION bin/res/)
+-install(FILES res/DSCope1.def.dsc DESTINATION bin/res/)
++install(FILES res/DSLogic.fw DESTINATION share/dsview/)
++install(FILES res/DSLogic33.bin DESTINATION share/dsview/)
++install(FILES res/DSLogic50.bin DESTINATION share/dsview/)
++install(FILES res/DSLogicPro.fw DESTINATION share/dsview/)
++install(FILES res/DSLogicPro.bin DESTINATION share/dsview/)
++install(FILES res/DSCope.fw DESTINATION share/dsview/)
++install(FILES res/DSCope.bin DESTINATION share/dsview/)
++install(FILES res/DSLogic0.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic0.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic1.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic1.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic2.dsc DESTINATION share/dsview/)
++install(FILES res/DSLogic2.def.dsc DESTINATION share/dsview/)
++install(FILES res/DSCope1.dsc DESTINATION share/dsview/)
++install(FILES res/DSCope1.def.dsc DESTINATION share/dsview/)
+
+ #===============================================================================
+ #= Packaging (handled by CPack)
+diff -Naur a/pv/devicemanager.cpp b/pv/devicemanager.cpp
+--- a/pv/devicemanager.cpp 2016-02-02 12:46:46.439429691 +0100
++++ b/pv/devicemanager.cpp 2016-02-02 12:53:09.256101381 +0100
+@@ -103,12 +103,16 @@
+
+ // Check If DSL hardware driver
+ if (strncmp(driver->name, "virtual", 7)) {
++ /*
+ QDir dir(QCoreApplication::applicationDirPath());
+ if (!dir.cd("res"))
+ return driver_devices;
+ QString str = dir.absolutePath() + "/";
+ QString str_utf8 = QString::fromLocal8Bit(str.toLocal8Bit());
+ strcpy(config_path, str_utf8.toUtf8().data());
++ */
++ // dirty
++ strcpy(config_path, "/usr/share/dsview/");
+ }
+
+ // Do the scan
diff --git a/udev.rules b/udev.rules
new file mode 100644
index 000000000000..443a1a99a83e
--- /dev/null
+++ b/udev.rules
@@ -0,0 +1,6 @@
+## DSLogic
+# 2a0e:0001
+ATTRS{idVendor}=="2a0e", ATTRS{idProduct}=="0001", ENV{ID_MM_DEVICE_IGNORE}="1"
+ATTRS{idVendor}=="2a0e", ATTRS{idProduct}=="0001", ENV{MTP_NO_PROBE}="1"
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="2a0e", ATTRS{idProduct}=="0001", GROUP="plugdev", MODE="0660"
+